aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-ounit
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-11 13:47:03 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-11 13:47:03 +0000
commit9d04f6211ef72c79ff798de934d66d6e71d6ef37 (patch)
treed476e5efa287661f29dd417e498677e33ffbe3c7 /devel/ocaml-ounit
parent41930dfa21f108b74fd96c6392abaca38f5c547a (diff)
downloadports-9d04f6211ef72c79ff798de934d66d6e71d6ef37.tar.gz
ports-9d04f6211ef72c79ff798de934d66d6e71d6ef37.zip
Notes
Diffstat (limited to 'devel/ocaml-ounit')
-rw-r--r--devel/ocaml-ounit/Makefile23
-rw-r--r--devel/ocaml-ounit/pkg-plist23
2 files changed, 24 insertions, 22 deletions
diff --git a/devel/ocaml-ounit/Makefile b/devel/ocaml-ounit/Makefile
index d570aefcccd1..e7457d91c31f 100644
--- a/devel/ocaml-ounit/Makefile
+++ b/devel/ocaml-ounit/Makefile
@@ -11,29 +11,24 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= OCaml unit test framework
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-
USES= gmake
-
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
+OCAML_PKGDIRS= oUnit
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-PORTDOCS= README style.css *.html
-
ALL_TARGET= all allopt testall doc
-
MAKE_ENV= OCAMLFIND_DESTDIR=${PREFIX}/lib/ocaml/site-lib
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} "==> Installing port documentation for ${PKGORIGIN}..."
- @${MKDIR} ${DOCSDIR}
- @( cd ${WRKSRC}; ${INSTALL_DATA} README ${DOCSDIR} )
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @( cd ${WRKSRC}; ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR} )
@( cd ${WRKSRC}/doc; \
- ${INSTALL_DATA} style.css ${DOCSDIR}; \
+ ${INSTALL_DATA} style.css ${STAGEDIR}${DOCSDIR}; \
for f in `${FIND} . -type f -name \\*.html -print`; do \
- ${INSTALL_DATA} $${f} ${DOCSDIR}; \
+ ${INSTALL_DATA} $${f} ${STAGEDIR}${DOCSDIR}; \
done )
-.endif
.include <bsd.port.mk>
diff --git a/devel/ocaml-ounit/pkg-plist b/devel/ocaml-ounit/pkg-plist
index a009cba84047..ff67b5606626 100644
--- a/devel/ocaml-ounit/pkg-plist
+++ b/devel/ocaml-ounit/pkg-plist
@@ -1,8 +1,15 @@
-lib/ocaml/site-lib/oUnit/oUnit.a
-lib/ocaml/site-lib/oUnit/oUnit.cmxa
-lib/ocaml/site-lib/oUnit/oUnit.cma
-lib/ocaml/site-lib/oUnit/oUnit.cmi
-lib/ocaml/site-lib/oUnit/oUnit.mli
-lib/ocaml/site-lib/oUnit/META
-@dirrm lib/ocaml/site-lib/oUnit
-@unexec ocamlfind remove oUnit 2> /dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/OUnit.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index_attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_class_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/index_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/index_module_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/index_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_values.html
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/type_OUnit.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%