aboutsummaryrefslogtreecommitdiff
path: root/devel/opencvs
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-04-20 20:19:31 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-04-20 20:19:31 +0000
commit2fb0b2f0ca7b0072f0b13f66b0c3adf9c19d4f12 (patch)
treee688be69708a32219550bf5620aedd4d207f1910 /devel/opencvs
parentd3408211236466c50fe860893fae90f80b6bc99b (diff)
downloadports-2fb0b2f0ca7b0072f0b13f66b0c3adf9c19d4f12.tar.gz
ports-2fb0b2f0ca7b0072f0b13f66b0c3adf9c19d4f12.zip
Notes
Diffstat (limited to 'devel/opencvs')
-rw-r--r--devel/opencvs/Makefile5
-rw-r--r--devel/opencvs/distinfo5
-rw-r--r--devel/opencvs/files/patch-Makefile28
-rw-r--r--devel/opencvs/files/patch-atomicio.h21
-rw-r--r--devel/opencvs/files/patch-checkout.c10
-rw-r--r--devel/opencvs/files/patch-cvs.c20
-rw-r--r--devel/opencvs/files/patch-cvs.h13
-rw-r--r--devel/opencvs/files/patch-log.h20
-rw-r--r--devel/opencvs/files/patch-rcs.h12
-rw-r--r--devel/opencvs/files/patch-rcsparse.h11
10 files changed, 63 insertions, 82 deletions
diff --git a/devel/opencvs/Makefile b/devel/opencvs/Makefile
index b42b10ff46fb..eca6de888568 100644
--- a/devel/opencvs/Makefile
+++ b/devel/opencvs/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= opencvs
-PORTVERSION= 20100608
+PORTVERSION= 20110420
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= johans
@@ -13,9 +13,12 @@ MASTER_SITE_SUBDIR= johans
MAINTAINER= johans@FreeBSD.org
COMMENT= BSD-licensed CVS implementation
+LICENSE= BSD
WRKSRC= ${WRKDIR}/cvs
MANCOMPRESSED= maybe
+MAN1= opencvs.1
+MAN5= opencvs.5
MAN7= cvsintro.7
MAKE_ENV+= BINDIR="${PREFIX}/bin" \
diff --git a/devel/opencvs/distinfo b/devel/opencvs/distinfo
index b3e1510831d7..fa7cc6934965 100644
--- a/devel/opencvs/distinfo
+++ b/devel/opencvs/distinfo
@@ -1,3 +1,2 @@
-MD5 (opencvs-20100608.tar.gz) = aa29e5a03f9bc792f10b4f2d0690f981
-SHA256 (opencvs-20100608.tar.gz) = feafd55c0778c5259768df01205134afe6f98fa7a17e8f9f72c8b0d867cbd857
-SIZE (opencvs-20100608.tar.gz) = 162138
+SHA256 (opencvs-20110420.tar.gz) = 407961cc917c779aa3399af7eae8e9813fcdbe3bc55dbf67434221a1208e16ca
+SIZE (opencvs-20110420.tar.gz) = 164005
diff --git a/devel/opencvs/files/patch-Makefile b/devel/opencvs/files/patch-Makefile
index 91de90f7e779..67b91828df5e 100644
--- a/devel/opencvs/files/patch-Makefile
+++ b/devel/opencvs/files/patch-Makefile
@@ -1,8 +1,17 @@
---- Makefile.orig 2008-06-21 17:39:15.000000000 +0200
-+++ Makefile 2010-06-08 20:18:08.000000000 +0200
-@@ -12,14 +12,8 @@
- server.c status.c tag.c trigger.c worklist.c util.c update.c version.c \
- watch.c xmalloc.c
+--- Makefile.orig 2011-04-20 20:46:33.000000000 +0200
++++ Makefile 2011-04-20 21:22:34.000000000 +0200
+@@ -1,7 +1,7 @@
+ # $OpenBSD: Makefile,v 1.48 2010/10/15 08:44:12 tobias Exp $
+
+ PROG= opencvs
+-MAN= cvsintro.7 # cvs.1 cvs.5
++MAN= cvsintro.7 opencvs.1 opencvs.5
+ CPPFLAGS+=-I${.CURDIR}
+
+ SRCS= cvs.c add.c admin.c annotate.c atomicio.c commit.c config.c \
+@@ -12,14 +12,14 @@
+ root.c server.c status.c tag.c trigger.c worklist.c util.c update.c \
+ version.c watch.c xmalloc.c
-CFLAGS+=-Wall
-CFLAGS+=-Wstrict-prototypes -Wmissing-prototypes
@@ -11,10 +20,15 @@
-CFLAGS+=-Wsign-compare
-DEBUG= -g -ggdb
-YFLAGS=
--
--INSTALL_STRIP=
+CFLAGS+=-DSIZE_MAX=ULONG_MAX
+DPADD+= ${LIBZ}
+LDADD+= -lz -lmd
+-INSTALL_STRIP=
++opencvs.1:
++ mv cvs.1 opencvs.1
++
++opencvs.5:
++ mv cvs.5 opencvs.5
+
.include <bsd.prog.mk>
diff --git a/devel/opencvs/files/patch-atomicio.h b/devel/opencvs/files/patch-atomicio.h
deleted file mode 100644
index e1b929cc197d..000000000000
--- a/devel/opencvs/files/patch-atomicio.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- atomicio.h.orig 2007-09-17 12:07:21.000000000 +0200
-+++ atomicio.h 2010-06-08 20:35:43.000000000 +0200
-@@ -28,6 +28,7 @@
-
- #ifndef _ATOMICIO_H
- #define _ATOMICIO_H
-+#include <sys/socket.h>
-
- /*
- * Ensure all of data on socket comes through. f==read || f==vwrite
-@@ -36,4 +37,10 @@ size_t atomicio(ssize_t (*)(int, void *,
-
- #define vwrite (ssize_t (*)(int, void *, size_t))write
-
-+/*
-+ * ensure all of data on socket comes through. f==readv || f==writev
-+ */
-+size_t atomiciov(ssize_t (*)(int, const struct iovec *, int),
-+ int, const struct iovec *, int);
-+
- #endif /* _ATOMICIO_H */
diff --git a/devel/opencvs/files/patch-checkout.c b/devel/opencvs/files/patch-checkout.c
deleted file mode 100644
index 2b333e1f2a63..000000000000
--- a/devel/opencvs/files/patch-checkout.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- checkout.c.orig 2009-06-21 22:23:01.000000000 +0200
-+++ checkout.c 2010-06-08 20:18:08.000000000 +0200
-@@ -364,6 +364,7 @@
- xfree(module_repo_root);
- }
-
-+#define TAILQ_END(head) NULL
- if (mc->mc_canfree == 1) {
- for (fl = RB_MIN(cvs_flisthead, &(mc->mc_modules));
- fl != NULL; fl = nxt) {
diff --git a/devel/opencvs/files/patch-cvs.c b/devel/opencvs/files/patch-cvs.c
deleted file mode 100644
index 882c27fd1756..000000000000
--- a/devel/opencvs/files/patch-cvs.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- cvs.c.orig 2008-06-21 17:39:15.000000000 +0200
-+++ cvs.c 2010-06-08 20:18:08.000000000 +0200
-@@ -70,7 +70,7 @@
- struct cvs_cmd *cmdp; /* struct of command we are running */
-
- int cvs_getopt(int, char **);
--__dead void usage(void);
-+void usage(void);
- static void cvs_read_rcfile(void);
-
- struct cvs_wklhead temp_files;
-@@ -122,7 +122,7 @@
- cvs_ent_close(current_list, ENT_SYNC);
- }
-
--__dead void
-+void
- usage(void)
- {
- (void)fprintf(stderr,
diff --git a/devel/opencvs/files/patch-cvs.h b/devel/opencvs/files/patch-cvs.h
index 3ef35bebfafd..ed6cd70bade5 100644
--- a/devel/opencvs/files/patch-cvs.h
+++ b/devel/opencvs/files/patch-cvs.h
@@ -1,10 +1,13 @@
---- cvs.h.orig 2009-03-25 22:19:20.000000000 +0100
-+++ cvs.h 2010-06-08 20:19:07.000000000 +0200
-@@ -28,6 +28,7 @@
- #define CVS_H
+--- cvs.h.orig 2009-03-25 14:19:20.000000000 -0700
++++ cvs.h 2011-04-18 23:55:35.000000000 -0700
+@@ -29,6 +29,10 @@
#include <signal.h>
-+#include <time.h>
++/* For building on FreeBSD */
++#include <time.h>
++#define __dead
++
#include "config.h"
#include "file.h"
+ #include "log.h"
diff --git a/devel/opencvs/files/patch-log.h b/devel/opencvs/files/patch-log.h
index 0c412f0bde6c..42b17cc21770 100644
--- a/devel/opencvs/files/patch-log.h
+++ b/devel/opencvs/files/patch-log.h
@@ -1,10 +1,12 @@
---- log.h.orig 2008-06-10 03:00:34.000000000 +0200
-+++ log.h 2010-06-08 20:18:08.000000000 +0200
-@@ -47,6 +47,6 @@
- void cvs_vlog(u_int, const char *, va_list);
- int cvs_printf(const char *, ...) __attribute__((format(printf, 1, 2)));
- int cvs_vprintf(const char *, va_list);
--void fatal(const char *, ...) __dead __attribute__((format(printf, 1,2)));
-+void fatal(const char *, ...) __attribute__((format(printf, 1,2)));
+--- log.h.orig 2008-06-09 18:00:34.000000000 -0700
++++ log.h 2011-04-18 23:44:44.000000000 -0700
+@@ -29,6 +29,9 @@
- #endif /* LOG_H */
+ #include <stdarg.h>
+
++/* For building on FreeBSD */
++#define __dead
++
+ /* log priority levels */
+ #define LP_NOTICE 0
+ #define LP_ERR 1
diff --git a/devel/opencvs/files/patch-rcs.h b/devel/opencvs/files/patch-rcs.h
index f057bb212217..c2f642fdd02e 100644
--- a/devel/opencvs/files/patch-rcs.h
+++ b/devel/opencvs/files/patch-rcs.h
@@ -1,10 +1,10 @@
---- rcs.h.orig 2010-06-08 20:26:06.000000000 +0200
-+++ rcs.h 2010-06-08 20:26:12.000000000 +0200
-@@ -26,6 +26,7 @@
-
- #ifndef RCS_H
+--- rcs.h.orig 2011-04-20 20:46:33.000000000 +0200
++++ rcs.h 2011-04-20 21:02:54.000000000 +0200
+@@ -28,6 +28,7 @@
#define RCS_H
+
+ #include <stdio.h>
+#include <time.h>
+
#include "buf.h"
- #define RCS_DIFF_DIV \
diff --git a/devel/opencvs/files/patch-rcsparse.h b/devel/opencvs/files/patch-rcsparse.h
new file mode 100644
index 000000000000..25c105127ffd
--- /dev/null
+++ b/devel/opencvs/files/patch-rcsparse.h
@@ -0,0 +1,11 @@
+--- rcsparse.c.orig 2011-04-20 21:08:22.000000000 +0200
++++ rcsparse.c 2011-04-20 21:08:46.000000000 +0200
+@@ -1221,8 +1221,6 @@
+ return 0;
+ }
+ }
+- if ((char *)cp - login_name > _PW_NAME_LEN)
+- return 0;
+ return 1;
+ }
+