aboutsummaryrefslogtreecommitdiff
path: root/devel/orbitcpp
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2002-03-12 01:18:37 +0000
committerAde Lovett <ade@FreeBSD.org>2002-03-12 01:18:37 +0000
commit25c7b3291077705f89ef1a429c8d780e7769ee25 (patch)
tree74b4144dc64704cda0bd80441f94d4ef189b7693 /devel/orbitcpp
parentb1a8647776f24d0b90ad3a46f508a73a099245fa (diff)
downloadports-25c7b3291077705f89ef1a429c8d780e7769ee25.tar.gz
ports-25c7b3291077705f89ef1a429c8d780e7769ee25.zip
Notes
Diffstat (limited to 'devel/orbitcpp')
-rw-r--r--devel/orbitcpp/Makefile15
-rw-r--r--devel/orbitcpp/distinfo2
-rw-r--r--devel/orbitcpp/files/patch-Makefile.am11
-rw-r--r--devel/orbitcpp/files/patch-Makefile.buildvars8
-rw-r--r--devel/orbitcpp/pkg-plist6
5 files changed, 12 insertions, 30 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index dc4743672af4..2c29528640c1 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -6,19 +6,24 @@
#
PORTNAME= orbitcpp
-PORTVERSION= 0.30.1
-PORTREVISION= 1
+PORTVERSION= 0.30.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= orbitcpp
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
-USE_GMAKE= yes
USE_GLIB= yes
-USE_AUTOMAKE_VER=14
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+INSTALL_CMD= /usr/bin/install -c -o ${BINOWN} -g ${BINGRP}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
+ 's|\@INSTALL\@|${INSTALL_CMD}|g'
+
.include <bsd.port.mk>
diff --git a/devel/orbitcpp/distinfo b/devel/orbitcpp/distinfo
index ad566d7dde5a..e7c949441bc8 100644
--- a/devel/orbitcpp/distinfo
+++ b/devel/orbitcpp/distinfo
@@ -1 +1 @@
-MD5 (orbitcpp-0.30.1.tar.gz) = 1268615115d6daf25e1aa92541ad5bcf
+MD5 (orbitcpp-0.30.4.tar.gz) = 3878aee7d05e8e86c6487e7f1429d6e9
diff --git a/devel/orbitcpp/files/patch-Makefile.am b/devel/orbitcpp/files/patch-Makefile.am
deleted file mode 100644
index 437bc027e92b..000000000000
--- a/devel/orbitcpp/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig Fri Feb 9 01:17:50 2001
-+++ Makefile.am Thu Nov 15 11:00:58 2001
-@@ -3,7 +3,7 @@
- # remove tests from global 'make' target if we don't have
- # orbit-idl --backenddir=<foo>
- if HAVE_ORBIT_IDL_BACKENDDIR
--SUBDIRS=compiler orb services test
-+SUBDIRS=compiler orb services
- else
- SUBDIRS=compiler orb
- endif
diff --git a/devel/orbitcpp/files/patch-Makefile.buildvars b/devel/orbitcpp/files/patch-Makefile.buildvars
deleted file mode 100644
index 81c330f2715e..000000000000
--- a/devel/orbitcpp/files/patch-Makefile.buildvars
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.buildvars.orig Thu Apr 5 11:57:48 2001
-+++ Makefile.buildvars Thu Nov 15 11:04:56 2001
-@@ -1,4 +1,4 @@
--INCLUDES= -I$(top_builddir) -I$(top_srcdir) $(ORBIT_CFLAGS)
-+INCLUDES= -I$(top_builddir) -I$(top_srcdir) -I${LOCALBASE}/include $(ORBIT_CFLAGS)
- # -ansi and -pedantic suck because of many superfluous warnings.
- FLAGS = -Wall
- CFLAGS = -g -O0 $(FLAGS)
diff --git a/devel/orbitcpp/pkg-plist b/devel/orbitcpp/pkg-plist
index 1fa11250e3f7..712198134e38 100644
--- a/devel/orbitcpp/pkg-plist
+++ b/devel/orbitcpp/pkg-plist
@@ -2,8 +2,6 @@ bin/orbitcpp-config
include/ORBitservices/CosNaming.hh
include/orb/orbitcpp.hh
include/orb/orbitcpp_any.hh
-include/orb/orbitcpp_config.hh
-include/orb/orbitcpp_constants.hh
include/orb/orbitcpp_exception.hh
include/orb/orbitcpp_exceptionlist.hh
include/orb/orbitcpp_object.hh
@@ -17,13 +15,11 @@ include/orb/orbitcpp_types.hh
include/orb/orbitcpp_var_smartptr.hh
lib/liborbitcpp.a
lib/liborbitcpp.so
-lib/liborbitcpp.so.30
+lib/liborbitcpp.so.31
lib/liborbitcppCosNaming.a
lib/liborbitcppCosNaming.so
lib/liborbitcppCosNaming.so.30
-lib/orbit-idl/liborbit-idl-c++-backend.a
lib/orbit-idl/liborbit-idl-c++-backend.so
-lib/orbit-idl/liborbit-idl-c++-backend.so.0
share/aclocal/orbitcpp.m4
@dirrm lib/orbit-idl
@dirrm include/orb