aboutsummaryrefslogtreecommitdiff
path: root/devel/p4
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-08 22:04:27 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-08 22:04:27 +0000
commitfe4d3785c2070f512288488a642a3a69b2387e1b (patch)
tree21eaa2f3d17f162ccabd163f094dc64fb65cda48 /devel/p4
parentb5a9157e2d3d6da50d3db2daf2c2c2fdd5fe945d (diff)
downloadports-fe4d3785c2070f512288488a642a3a69b2387e1b.tar.gz
ports-fe4d3785c2070f512288488a642a3a69b2387e1b.zip
Notes
Diffstat (limited to 'devel/p4')
-rw-r--r--devel/p4/Makefile16
-rw-r--r--devel/p4/Makefile.inc24
-rw-r--r--devel/p4/distinfo.amd642
-rw-r--r--devel/p4/distinfo.freebsd100x862
-rw-r--r--devel/p4/distinfo.freebsd100x86_642
-rw-r--r--devel/p4/distinfo.freebsd70x862
-rw-r--r--devel/p4/distinfo.freebsd70x86_642
-rw-r--r--devel/p4/distinfo.i3862
8 files changed, 42 insertions, 10 deletions
diff --git a/devel/p4/Makefile b/devel/p4/Makefile
index be104bbb76e3..074f206672c6 100644
--- a/devel/p4/Makefile
+++ b/devel/p4/Makefile
@@ -4,7 +4,8 @@
PORTNAME= p4
PORTVERSION= 2014.2.1045032
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.perforce.com/perforce/${P4VERSION}/bin.freebsd100${ARCH:S,i386,x86,:S,amd64,x86_64,}/
+MASTER_SITES= ftp://ftp.perforce.com/perforce/${P4VERSION}/bin.${PLATFORM}/ \
+ http://filehost.perforce.com/perforce/${P4VERSION}/bin.${PLATFORM}/
DISTNAME= p4
EXTRACT_SUFX=
EXTRACT_ONLY= # none
@@ -12,14 +13,13 @@ EXTRACT_ONLY= # none
MAINTAINER= gordon@FreeBSD.org
COMMENT= Perforce client
-BROKEN_FreeBSD_8= no distfiles
-BROKEN_FreeBSD_9= no distfiles
-BROKEN_FreeBSD_11= no distfiles
+BROKEN= checksum mismatch
ONLY_FOR_ARCHS= amd64 i386
P4VERSION= r${PORTVERSION:S/^20//:C/\.[0-9]+$//}
-DISTINFO_FILE= ${MASTERDIR}/distinfo.${ARCH}
+DIST_SUBDIR= perforce/${PORTVERSION}/bin.${PLATFORM}
+DISTINFO_FILE= ${MASTERDIR}/distinfo.${PLATFORM}
RESTRICTED= Restricted distribution
@@ -28,7 +28,11 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/p4
+.include <bsd.port.pre.mk>
+
+.include "Makefile.inc"
+
do-install:
${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/p4 ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p4/Makefile.inc b/devel/p4/Makefile.inc
new file mode 100644
index 000000000000..05c2fdb6aa7c
--- /dev/null
+++ b/devel/p4/Makefile.inc
@@ -0,0 +1,24 @@
+# Figure out what to install
+.if ${OPSYS} == FreeBSD
+
+.if ${ARCH} == amd64
+. if ${OSVERSION} >= 1000100
+PLATFORM= freebsd100x86_64
+. else
+PLATFORM= freebsd70x86_64
+. endif
+
+.elif ${ARCH} == i386
+. if ${OSVERSION} >= 1000100
+PLATFORM= freebsd100x86
+. else
+PLATFORM= freebsd70x86
+. endif
+
+.else
+IGNORE= unsupported OS release, sorry
+.endif
+
+.else
+IGNORE= ${OPSYS} is unsupported, sorry
+.endif
diff --git a/devel/p4/distinfo.amd64 b/devel/p4/distinfo.amd64
deleted file mode 100644
index ee9e16420e1c..000000000000
--- a/devel/p4/distinfo.amd64
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (p4) = af4570d58a2dbb981ea87cfabdf5993272d3c7e366fdb3db5a8a327d491c3e16
-SIZE (p4) = 2755088
diff --git a/devel/p4/distinfo.freebsd100x86 b/devel/p4/distinfo.freebsd100x86
new file mode 100644
index 000000000000..3c6005aa8e34
--- /dev/null
+++ b/devel/p4/distinfo.freebsd100x86
@@ -0,0 +1,2 @@
+SHA256 (perforce/2014.2.1045032/bin.freebsd100x86/p4) = 1261bacd887cb09bcf79004a427784e3428ebef8ef7f8cd527e8f446feb3efb4
+SIZE (perforce/2014.2.1045032/bin.freebsd100x86/p4) = 2474416
diff --git a/devel/p4/distinfo.freebsd100x86_64 b/devel/p4/distinfo.freebsd100x86_64
new file mode 100644
index 000000000000..6eab93013b43
--- /dev/null
+++ b/devel/p4/distinfo.freebsd100x86_64
@@ -0,0 +1,2 @@
+SHA256 (perforce/2014.2.1045032/bin.freebsd100x86_64/p4) = 676c424b485e90817e63592fc5f14ea151b489128078053989f2e85080d485c2
+SIZE (perforce/2014.2.1045032/bin.freebsd100x86_64/p4) = 2732720
diff --git a/devel/p4/distinfo.freebsd70x86 b/devel/p4/distinfo.freebsd70x86
new file mode 100644
index 000000000000..92bc1b5f82af
--- /dev/null
+++ b/devel/p4/distinfo.freebsd70x86
@@ -0,0 +1,2 @@
+SHA256 (perforce/2014.2.1045032/bin.freebsd70x86/p4) = 0c48532af152ba9ef187fd3a098ec0be0c5f8b9312becea4a27fe63ddec427ac
+SIZE (perforce/2014.2.1045032/bin.freebsd70x86/p4) = 2555504
diff --git a/devel/p4/distinfo.freebsd70x86_64 b/devel/p4/distinfo.freebsd70x86_64
new file mode 100644
index 000000000000..fab6ee8a2ef6
--- /dev/null
+++ b/devel/p4/distinfo.freebsd70x86_64
@@ -0,0 +1,2 @@
+SHA256 (perforce/2014.2.1045032/bin.freebsd70x86_64/p4) = 3fbf5e0203bf4c2bc9b6107c8111c28e9d2f88372f6330fcff32057addf6c069
+SIZE (perforce/2014.2.1045032/bin.freebsd70x86_64/p4) = 2716456
diff --git a/devel/p4/distinfo.i386 b/devel/p4/distinfo.i386
deleted file mode 100644
index d234bd3ab5b0..000000000000
--- a/devel/p4/distinfo.i386
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (p4) = 9bb15090a217e61d09f301f668f8e3828592516afe74e90e837ff93d21301750
-SIZE (p4) = 2500176