aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-App-CLI/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 23:11:40 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 23:11:40 +0000
commit5693c4fbe07314543a540fdd711c5998645687d6 (patch)
treeff738223ad709642ae98253149d0b5a76ca4fd72 /devel/p5-App-CLI/Makefile
parentf638aa114b1e2bebcc632be3dfc0e9b281fc0776 (diff)
downloadports-5693c4fbe07314543a540fdd711c5998645687d6.tar.gz
ports-5693c4fbe07314543a540fdd711c5998645687d6.zip
Notes
Diffstat (limited to 'devel/p5-App-CLI/Makefile')
-rw-r--r--devel/p5-App-CLI/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/devel/p5-App-CLI/Makefile b/devel/p5-App-CLI/Makefile
index fbb15612c042..9eec8bdbbe3a 100644
--- a/devel/p5-App-CLI/Makefile
+++ b/devel/p5-App-CLI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= App-CLI
-PORTVERSION= 0.08
+PORTVERSION= 0.103
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,15 +14,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= App::CLI - Dispatcher module for command line interface programs
-BUILD_DEPENDS= \
- p5-Locale-Maketext-Simple>0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
- p5-Pod-Simple>0:${PORTSDIR}/textproc/p5-Pod-Simple \
- p5-Getopt-Long>=2.34:${PORTSDIR}/devel/p5-Getopt-Long
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-MAN3= App::CLI.3 \
- App::CLI::Command.3
+MAN3= App::CLI.3 App::CLI::Command.3 App::CLI::Command::Help.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS= p5-Getopt-Long>=2.34:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-Locale-Maketext-Simple>0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ p5-Pod-Simple>0:${PORTSDIR}/textproc/p5-Pod-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>