aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Cache-Cache
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-07-05 02:24:55 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-07-05 02:24:55 +0000
commite42c0b351e454e98603b05a08b17d68f72229f7d (patch)
tree798297dc1228091c4d5c55858186f44c3f06a85d /devel/p5-Cache-Cache
parent535649228ace37330da2d7e95dee35eec8ece820 (diff)
downloadports-e42c0b351e454e98603b05a08b17d68f72229f7d.tar.gz
ports-e42c0b351e454e98603b05a08b17d68f72229f7d.zip
Notes
Diffstat (limited to 'devel/p5-Cache-Cache')
-rw-r--r--devel/p5-Cache-Cache/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/devel/p5-Cache-Cache/Makefile b/devel/p5-Cache-Cache/Makefile
index dc68bc8caa08..0980a3ede455 100644
--- a/devel/p5-Cache-Cache/Makefile
+++ b/devel/p5-Cache-Cache/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Cache-Cache
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,13 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Cache::Cache -- Perl Cache interface
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache \
+ p5-Digest-SHA1>=2.02:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Error>=0.15:${PORTSDIR}/lang/p5-Error \
+ p5-IPC-ShareLite>=0.09:${PORTSDIR}/devel/p5-IPC-ShareLite
PERL_CONFIGURE= yes
@@ -45,4 +43,10 @@ MAN3= Cache::BaseCache.3 \
Cache::SizeAwareMemoryCache.3 \
Cache::SizeAwareSharedMemoryCache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Storable>=1.014:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>