aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Accessor-Fast-Contained
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:31:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:31:02 +0000
commiteda2e2c4a7b2167e5cbaf3671348219e0a1abeea (patch)
treed48e010e179dfc137ae796255c03543faa093757 /devel/p5-Class-Accessor-Fast-Contained
parentd7a5baa932d68a5f57f7df05a26ab0952b91e2b2 (diff)
downloadports-eda2e2c4a7b2167e5cbaf3671348219e0a1abeea.tar.gz
ports-eda2e2c4a7b2167e5cbaf3671348219e0a1abeea.zip
Notes
Diffstat (limited to 'devel/p5-Class-Accessor-Fast-Contained')
-rw-r--r--devel/p5-Class-Accessor-Fast-Contained/Makefile27
-rw-r--r--devel/p5-Class-Accessor-Fast-Contained/distinfo3
-rw-r--r--devel/p5-Class-Accessor-Fast-Contained/pkg-descr10
-rw-r--r--devel/p5-Class-Accessor-Fast-Contained/pkg-plist9
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/p5-Class-Accessor-Fast-Contained/Makefile b/devel/p5-Class-Accessor-Fast-Contained/Makefile
new file mode 100644
index 000000000000..49413bd564d1
--- /dev/null
+++ b/devel/p5-Class-Accessor-Fast-Contained/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-Class-Accessor-Fast-Contained
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Accessor-Fast-Contained
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Fast accessors with data containment
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Accessor::Fast::Contained.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Accessor-Fast-Contained/distinfo b/devel/p5-Class-Accessor-Fast-Contained/distinfo
new file mode 100644
index 000000000000..f5c8e26f9249
--- /dev/null
+++ b/devel/p5-Class-Accessor-Fast-Contained/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Accessor-Fast-Contained-1.01.tar.gz) = f3f070cb158102e2af4149a5d27dd2d8
+SHA256 (Class-Accessor-Fast-Contained-1.01.tar.gz) = b829964bd47e4a7ff7f8f94cd1c1e32f9cbf8afce347b2ddfd49de5e15a616ad
+SIZE (Class-Accessor-Fast-Contained-1.01.tar.gz) = 15958
diff --git a/devel/p5-Class-Accessor-Fast-Contained/pkg-descr b/devel/p5-Class-Accessor-Fast-Contained/pkg-descr
new file mode 100644
index 000000000000..8abf8901ff18
--- /dev/null
+++ b/devel/p5-Class-Accessor-Fast-Contained/pkg-descr
@@ -0,0 +1,10 @@
+This module does two things differently to the venerable
+Class::Accessor::Fast:
+
+- Fields are stored at arms-length within a single hash value of $self, rather
+ than directly in the $self blessed referent.
+
+- new() allows mixin into an existing object, rather than creating and
+ returning a new blessed hashref.
+
+WWW: http://search.cpan.org/dist/Class-Accessor-Fast-Contained/
diff --git a/devel/p5-Class-Accessor-Fast-Contained/pkg-plist b/devel/p5-Class-Accessor-Fast-Contained/pkg-plist
new file mode 100644
index 000000000000..4e00a39bdf5a
--- /dev/null
+++ b/devel/p5-Class-Accessor-Fast-Contained/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Class/Accessor/Fast/Contained.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Accessor/Fast/Contained/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Accessor/Fast/Contained
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Accessor/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Accessor
+@dirrmtry %%SITE_PERL%%/Class/Accessor/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class/Accessor
+@dirrmtry %%SITE_PERL%%/Class