aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-CodeStyler
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-13 02:39:21 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-13 02:39:21 +0000
commit51db51165c358a7007bea6c885fa26b37c8ab2e6 (patch)
treeb07a7ccec133152caabaeafc96c995ad3238860f /devel/p5-Class-CodeStyler
parentaf81c01a21116dc1c4d0204ffa901d1f2bd6d1ab (diff)
downloadports-51db51165c358a7007bea6c885fa26b37c8ab2e6.tar.gz
ports-51db51165c358a7007bea6c885fa26b37c8ab2e6.zip
Notes
Diffstat (limited to 'devel/p5-Class-CodeStyler')
-rw-r--r--devel/p5-Class-CodeStyler/Makefile29
-rw-r--r--devel/p5-Class-CodeStyler/distinfo3
-rw-r--r--devel/p5-Class-CodeStyler/pkg-descr8
-rw-r--r--devel/p5-Class-CodeStyler/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Class-CodeStyler/Makefile b/devel/p5-Class-CodeStyler/Makefile
new file mode 100644
index 000000000000..9ea6f49b87e7
--- /dev/null
+++ b/devel/p5-Class-CodeStyler/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Class-CodeStyler
+# Date created: 12 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-CodeStyler
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for code generation program formatting and execution
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/STL/Containers.pm:${PORTSDIR}/devel/p5-Class-STL-Containers
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500807
+IGNORE= requires at least Perl 5.8.7. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-CodeStyler/distinfo b/devel/p5-Class-CodeStyler/distinfo
new file mode 100644
index 000000000000..aa2d90264036
--- /dev/null
+++ b/devel/p5-Class-CodeStyler/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-CodeStyler-0.07.tar.gz) = 731668fd10c45847fb754e22d3f60866
+SHA256 (Class-CodeStyler-0.07.tar.gz) = 665dd0739da2770fa471b87d96ed422ab90126b543051cc10bf94275b1a3fb2d
+SIZE (Class-CodeStyler-0.07.tar.gz) = 14276
diff --git a/devel/p5-Class-CodeStyler/pkg-descr b/devel/p5-Class-CodeStyler/pkg-descr
new file mode 100644
index 000000000000..c173a753105e
--- /dev/null
+++ b/devel/p5-Class-CodeStyler/pkg-descr
@@ -0,0 +1,8 @@
+Class::CodeStyler is an object oriented API to be used by code-gererators
+in producing formatted code (Perl, C, other). The produced code file can
+also be syntax checked, displayed with line numbers, executed, and eval'd.
+Code can be inserted anywhere in the generated program using a system of
+bookmarks and jumps.
+
+WWW: http://search.cpan.org/dist/Class-CodeStyler
+Author: m gaffiero <gaffie@users.sourceforge.net>
diff --git a/devel/p5-Class-CodeStyler/pkg-plist b/devel/p5-Class-CodeStyler/pkg-plist
new file mode 100644
index 000000000000..299b7fe0472e
--- /dev/null
+++ b/devel/p5-Class-CodeStyler/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/CodeStyler.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/CodeStyler/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/CodeStyler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class