aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Contract
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-04-08 16:24:46 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-04-08 16:24:46 +0000
commit914b4608304eb8590f39e7de96e05b9da57cfb3f (patch)
treeb8d2f639dd3b6329176d71f17cc3550764a59083 /devel/p5-Class-Contract
parent5cd12d72b7e4b9009f2fba483e3535ca2086147d (diff)
downloadports-914b4608304eb8590f39e7de96e05b9da57cfb3f.tar.gz
ports-914b4608304eb8590f39e7de96e05b9da57cfb3f.zip
Notes
Diffstat (limited to 'devel/p5-Class-Contract')
-rw-r--r--devel/p5-Class-Contract/Makefile4
-rw-r--r--devel/p5-Class-Contract/pkg-descr11
-rw-r--r--devel/p5-Class-Contract/pkg-plist4
3 files changed, 12 insertions, 7 deletions
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index 7353cac2830a..040105d4f9c2 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -12,11 +12,12 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Class
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos
PERL_CONFIGURE= yes
+PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Class::Contract.3 Class::Contract::Production.3
@@ -30,6 +31,7 @@ pre-configure:
post-install:
.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
${PREFIX}/share/examples/${PORTNAME}
diff --git a/devel/p5-Class-Contract/pkg-descr b/devel/p5-Class-Contract/pkg-descr
index fb9dc3d35ab4..9297680e87b0 100644
--- a/devel/p5-Class-Contract/pkg-descr
+++ b/devel/p5-Class-Contract/pkg-descr
@@ -1,8 +1,11 @@
The Class::Contract module implements strong encapsulation, static
inheritance, and design-by-contract condition checking for
-object-oriented Perl. The module provides a declarative syntax for
-attribute, method, constructor, and destructor definitions at both
-the object and class level. Pre-conditions, post-conditions, and
-class invariants are also fully supported.
+object-oriented Perl. The module provides a declarative syntax for
+attribute, method, constructor, and destructor definitions at both the
+object and class level. Pre-conditions, post-conditions, and class
+invariants are also fully supported.
WWW: http://search.cpan.org/search?dist=Class-Contract
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Class-Contract/pkg-plist b/devel/p5-Class-Contract/pkg-plist
index 2faabd3cc5c4..74e53c6298cf 100644
--- a/devel/p5-Class-Contract/pkg-plist
+++ b/devel/p5-Class-Contract/pkg-plist
@@ -1,8 +1,8 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Contract/.packlist
lib/perl5/site_perl/%%PERL_VER%%/Class/Contract.pm
lib/perl5/site_perl/%%PERL_VER%%/Class/Contract/Production.pm
-%%PORTDOCS%%share/examples/Class-Contract/demo.pl
-%%PORTDOCS%%@dirrm share/examples/Class-Contract
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class/Contract
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Contract
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true