aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Multimethods-Pure
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 01:09:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 01:09:47 +0000
commit30906c9a2c0449e124e86df2c7963231dd844170 (patch)
tree97971316cad3df3d4b0667ce6accdd069b9b4d79 /devel/p5-Class-Multimethods-Pure
parenteb961371c00a448fd44a72d408bb74c767e9ed7c (diff)
downloadports-30906c9a2c0449e124e86df2c7963231dd844170.tar.gz
ports-30906c9a2c0449e124e86df2c7963231dd844170.zip
Notes
Diffstat (limited to 'devel/p5-Class-Multimethods-Pure')
-rw-r--r--devel/p5-Class-Multimethods-Pure/Makefile28
-rw-r--r--devel/p5-Class-Multimethods-Pure/distinfo3
-rw-r--r--devel/p5-Class-Multimethods-Pure/pkg-descr17
-rw-r--r--devel/p5-Class-Multimethods-Pure/pkg-plist8
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/p5-Class-Multimethods-Pure/Makefile b/devel/p5-Class-Multimethods-Pure/Makefile
new file mode 100644
index 000000000000..51ad02ff9c48
--- /dev/null
+++ b/devel/p5-Class-Multimethods-Pure/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Class-Multimethods-Pure
+# Date created: 2006-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Multimethods-Pure
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Method-ordered multimethod dispatch
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Multimethods::Pure.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Multimethods-Pure/distinfo b/devel/p5-Class-Multimethods-Pure/distinfo
new file mode 100644
index 000000000000..c7c110e8da6a
--- /dev/null
+++ b/devel/p5-Class-Multimethods-Pure/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Multimethods-Pure-0.11.tar.gz) = 611aa6b2fe51331b40f9060fd73fbd30
+SHA256 (Class-Multimethods-Pure-0.11.tar.gz) = f6c98c18870cedd556268f43bb093609f1b00ca5e039de2c09f057d88a2a4b1c
+SIZE (Class-Multimethods-Pure-0.11.tar.gz) = 13056
diff --git a/devel/p5-Class-Multimethods-Pure/pkg-descr b/devel/p5-Class-Multimethods-Pure/pkg-descr
new file mode 100644
index 000000000000..8cc850b4811d
--- /dev/null
+++ b/devel/p5-Class-Multimethods-Pure/pkg-descr
@@ -0,0 +1,17 @@
+You can define multimethods with the "multi" declarator:
+
+ use Class::Multimethods::Pure;
+
+ multi collide => ('Bullet', 'Ship') => sub {
+ my ($a, $b) = @_; ...
+ };
+
+ multi collide => ('Ship', 'Asteroid') => sub {
+ my ($a, $b) = @_; ...
+ };
+
+It is usually wise to put such declarations within a BEGIN block, so
+they behave more like Perl treats subs (you can call them without
+parentheses and you can use them before you define them).
+
+WWW: http://search.cpan.org/dist/Class-Multimethods-Pure/
diff --git a/devel/p5-Class-Multimethods-Pure/pkg-plist b/devel/p5-Class-Multimethods-Pure/pkg-plist
new file mode 100644
index 000000000000..17f067f5ace0
--- /dev/null
+++ b/devel/p5-Class-Multimethods-Pure/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Multimethods/Pure/.packlist
+%%SITE_PERL%%/Class/Multimethods/Pure.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Multimethods/Pure
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Multimethods
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class/Multimethods
+@dirrmtry %%SITE_PERL%%/Class