aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Code-Perl
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:02:50 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:02:50 +0000
commit62878e1473ebcdde07e74d3b67f06b1bcb9913ba (patch)
treebd888c0902a03e523629e4836c2c08897a0fd26d /devel/p5-Code-Perl
parentad1cf3804e7287e774bbfb82da81ae2fa1180ac9 (diff)
downloadports-62878e1473ebcdde07e74d3b67f06b1bcb9913ba.tar.gz
ports-62878e1473ebcdde07e74d3b67f06b1bcb9913ba.zip
Notes
Diffstat (limited to 'devel/p5-Code-Perl')
-rw-r--r--devel/p5-Code-Perl/Makefile32
-rw-r--r--devel/p5-Code-Perl/distinfo3
-rw-r--r--devel/p5-Code-Perl/pkg-descr9
-rw-r--r--devel/p5-Code-Perl/pkg-plist28
4 files changed, 72 insertions, 0 deletions
diff --git a/devel/p5-Code-Perl/Makefile b/devel/p5-Code-Perl/Makefile
new file mode 100644
index 000000000000..85ecc0fd9e83
--- /dev/null
+++ b/devel/p5-Code-Perl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Code-Perl
+# Date created: 26 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Code-Perl
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/F/FD/FDALY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Produce Perl code from a tree
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Code::Perl.3 Code::Perl::Expr.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Code-Perl/distinfo b/devel/p5-Code-Perl/distinfo
new file mode 100644
index 000000000000..310b8effca49
--- /dev/null
+++ b/devel/p5-Code-Perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Code-Perl-0.03.tar.gz) = 58a87e4703c0420f302a6a44312121ff
+SHA256 (Code-Perl-0.03.tar.gz) = d95957e2f3f46edd90d621ea8e4b76764d35ac64283ca0e0a0b951a24900a935
+SIZE (Code-Perl-0.03.tar.gz) = 17580
diff --git a/devel/p5-Code-Perl/pkg-descr b/devel/p5-Code-Perl/pkg-descr
new file mode 100644
index 000000000000..ce33ac83d914
--- /dev/null
+++ b/devel/p5-Code-Perl/pkg-descr
@@ -0,0 +1,9 @@
+Code::Perl allows you to build chunks of Perl code as a tree and then when
+you're finished building, the tree can output the Perl code. This is
+useful if you have built your own mini-language and you want to generate
+Perl from it. Rather than generating the Perl at parse time and having to
+worry about quoting, escaping, parenthese etc, you can just build a tree
+using Code::Perl and then dump out the correct Perl at the end.
+
+WWW: http://search.cpan.org/dist/Code-Perl
+Author: Fergal Daly <fergal@esatclear.ie>
diff --git a/devel/p5-Code-Perl/pkg-plist b/devel/p5-Code-Perl/pkg-plist
new file mode 100644
index 000000000000..599cc8205f3a
--- /dev/null
+++ b/devel/p5-Code-Perl/pkg-plist
@@ -0,0 +1,28 @@
+%%SITE_PERL%%/Code/Perl.pm
+%%SITE_PERL%%/Code/Perl.pod
+%%SITE_PERL%%/Code/Perl/Base.pm
+%%SITE_PERL%%/Code/Perl/Expr.pm
+%%SITE_PERL%%/Code/Perl/Expr/Append.pm
+%%SITE_PERL%%/Code/Perl/Expr/Base.pm
+%%SITE_PERL%%/Code/Perl/Expr/CallMethod.pm
+%%SITE_PERL%%/Code/Perl/Expr/CallSub.pm
+%%SITE_PERL%%/Code/Perl/Expr/Constant.pm
+%%SITE_PERL%%/Code/Perl/Expr/DerefArray.pm
+%%SITE_PERL%%/Code/Perl/Expr/DerefHash.pm
+%%SITE_PERL%%/Code/Perl/Expr/Holder.pm
+%%SITE_PERL%%/Code/Perl/Expr/Infix.pm
+%%SITE_PERL%%/Code/Perl/Expr/List.pm
+%%SITE_PERL%%/Code/Perl/Expr/Not.pm
+%%SITE_PERL%%/Code/Perl/Expr/Number.pm
+%%SITE_PERL%%/Code/Perl/Expr/Perl.pm
+%%SITE_PERL%%/Code/Perl/Expr/Scalar.pm
+%%SITE_PERL%%/Code/Perl/Expr/String.pm
+%%SITE_PERL%%/Code/Perl/Expr/SubName.pm
+%%SITE_PERL%%/Code/Perl/Test/Expr.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Code/Perl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Code/Perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Code
+@dirrm %%SITE_PERL%%/Code/Perl/Test
+@dirrm %%SITE_PERL%%/Code/Perl/Expr
+@dirrm %%SITE_PERL%%/Code/Perl
+@dirrmtry %%SITE_PERL%%/Code