aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-JavaScript-Anon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-08 10:20:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-08 10:20:40 +0000
commit6c4831e7ae0ed42431fffe5fad2f5e634510bd87 (patch)
treec954d78b53665c4fa5d963cf5859988013a6bab5 /devel/p5-Data-JavaScript-Anon
parentddf032deebb431b0976e3031c61043d12820968e (diff)
downloadports-6c4831e7ae0ed42431fffe5fad2f5e634510bd87.tar.gz
ports-6c4831e7ae0ed42431fffe5fad2f5e634510bd87.zip
Notes
Diffstat (limited to 'devel/p5-Data-JavaScript-Anon')
-rw-r--r--devel/p5-Data-JavaScript-Anon/Makefile25
-rw-r--r--devel/p5-Data-JavaScript-Anon/distinfo3
-rw-r--r--devel/p5-Data-JavaScript-Anon/pkg-descr5
-rw-r--r--devel/p5-Data-JavaScript-Anon/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Data-JavaScript-Anon/Makefile b/devel/p5-Data-JavaScript-Anon/Makefile
new file mode 100644
index 000000000000..5ecaa37d8cf1
--- /dev/null
+++ b/devel/p5-Data-JavaScript-Anon/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: devel-p5-Data-JavaScript-Anon
+# Date created: 03 April 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-JavaScript-Anon
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Dump big dumb Perl structs to anonymous JavaScript structs
+
+RUN_DEPENDS= p5-Class-Default>=1.51:${PORTSDIR}/devel/p5-Class-Default \
+ p5-Params-Util>=0.01:${PORTSDIR}/devel/p5-Params-Util
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= Data::JavaScript::Anon.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-JavaScript-Anon/distinfo b/devel/p5-Data-JavaScript-Anon/distinfo
new file mode 100644
index 000000000000..1be3b5ce5c2a
--- /dev/null
+++ b/devel/p5-Data-JavaScript-Anon/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-JavaScript-Anon-1.03.tar.gz) = 6808b24eaa719b9303f904e0388f3ce3
+SHA256 (Data-JavaScript-Anon-1.03.tar.gz) = 0c2faa96fbf1bda0cb89b8f0be2764acc0a2cb2e2440deb781e03da02597b182
+SIZE (Data-JavaScript-Anon-1.03.tar.gz) = 30889
diff --git a/devel/p5-Data-JavaScript-Anon/pkg-descr b/devel/p5-Data-JavaScript-Anon/pkg-descr
new file mode 100644
index 000000000000..e83aade5d97b
--- /dev/null
+++ b/devel/p5-Data-JavaScript-Anon/pkg-descr
@@ -0,0 +1,5 @@
+Data::JavaScript::Anon provides the ability to dump large
+simple data structures to JavaScript. That is, things that
+don't need to be a class, or have special methods or whatever.
+
+WWW: http://search.cpan.org/dist/Data-JavaScript-Anon/
diff --git a/devel/p5-Data-JavaScript-Anon/pkg-plist b/devel/p5-Data-JavaScript-Anon/pkg-plist
new file mode 100644
index 000000000000..88cc4f0e931b
--- /dev/null
+++ b/devel/p5-Data-JavaScript-Anon/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Data/JavaScript/Anon.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/JavaScript/Anon/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/JavaScript/Anon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/JavaScript
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/Data/JavaScript
+@dirrmtry %%SITE_PERL%%/Data