aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Page-NoTotalEntries/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-02-26 14:07:33 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-02-26 14:07:33 +0000
commit98d1fbd267a360e12958867c2e00c60242d620e1 (patch)
treeaefaa259877a5c585facd1a516a7b0f3ca1a2cd4 /devel/p5-Data-Page-NoTotalEntries/Makefile
parent6567a7a0a086d8e05a4420276941e0281ce00eb4 (diff)
downloadports-98d1fbd267a360e12958867c2e00c60242d620e1.tar.gz
ports-98d1fbd267a360e12958867c2e00c60242d620e1.zip
Notes
Diffstat (limited to 'devel/p5-Data-Page-NoTotalEntries/Makefile')
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-Data-Page-NoTotalEntries/Makefile b/devel/p5-Data-Page-NoTotalEntries/Makefile
new file mode 100644
index 000000000000..47f4ab086dfa
--- /dev/null
+++ b/devel/p5-Data-Page-NoTotalEntries/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Data::Page::NoTotalEntries
+# Date created: 26 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Page-NoTotalEntries
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/T/TO/TOKUHIROM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for paging results without total entries
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Page::NoTotalEntries.3 \
+ Data::Page::README.3
+
+.include <bsd.port.mk>