aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-PartialDump/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-05-11 19:26:25 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-05-11 19:26:25 +0000
commitc3920b1799a8ce765ea85cf4c3a3aa0ea9013f22 (patch)
tree0520e4be4ea6538fba1b5ea804be0cecdcc30dfb /devel/p5-Devel-PartialDump/Makefile
parentd38080391a33b304b4eff26d4c12410d865d5e4e (diff)
downloadports-c3920b1799a8ce765ea85cf4c3a3aa0ea9013f22.tar.gz
ports-c3920b1799a8ce765ea85cf4c3a3aa0ea9013f22.zip
Notes
Diffstat (limited to 'devel/p5-Devel-PartialDump/Makefile')
-rw-r--r--devel/p5-Devel-PartialDump/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Devel-PartialDump/Makefile b/devel/p5-Devel-PartialDump/Makefile
new file mode 100644
index 000000000000..1b0b851b29d9
--- /dev/null
+++ b/devel/p5-Devel-PartialDump/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Devel-PartialDump
+# Date created: 11 May 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-PartialDump
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Partial dumping of data structures, optimized for argument printing
+
+BUILD_DEPENDS= p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-namespace-clean>=0.08:${PORTSDIR}/devel/p5-namespace-clean \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Devel::PartialDump.3
+
+.include <bsd.port.mk>