aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-StealthDebug/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-19 14:17:35 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-19 14:17:35 +0000
commitbb9d4889656e09558f1b503cf8d4889ff8701e7a (patch)
tree0b602ff43da24ba8ab2c68da86d4f25dae33e665 /devel/p5-Devel-StealthDebug/Makefile
parent6ade5dd247b2fc45b8d6c68db50f2d39a7dfcea4 (diff)
downloadports-bb9d4889656e09558f1b503cf8d4889ff8701e7a.tar.gz
ports-bb9d4889656e09558f1b503cf8d4889ff8701e7a.zip
Notes
Diffstat (limited to 'devel/p5-Devel-StealthDebug/Makefile')
-rw-r--r--devel/p5-Devel-StealthDebug/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-Devel-StealthDebug/Makefile b/devel/p5-Devel-StealthDebug/Makefile
new file mode 100644
index 000000000000..409f29067172
--- /dev/null
+++ b/devel/p5-Devel-StealthDebug/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Devel-StealthDebug
+# Date created: August 18th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-StealthDebug
+PORTVERSION= 1.008
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Simple non-intrusive debug module
+
+BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Devel::StealthDebug.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/StealthDebug.pm
+.endif
+
+.include <bsd.port.post.mk>