aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Exception-Class-TryCatch
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 20:29:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 20:29:25 +0000
commitb334d2ac09d9498aa367d659e02798ba0f18be8c (patch)
tree39100ec61660e61051e7ce756822229b9b16eb41 /devel/p5-Exception-Class-TryCatch
parent6a512db90d6a12f2ec90fe785663d4a705311809 (diff)
downloadports-b334d2ac09d9498aa367d659e02798ba0f18be8c.tar.gz
ports-b334d2ac09d9498aa367d659e02798ba0f18be8c.zip
Notes
Diffstat (limited to 'devel/p5-Exception-Class-TryCatch')
-rw-r--r--devel/p5-Exception-Class-TryCatch/Makefile26
-rw-r--r--devel/p5-Exception-Class-TryCatch/distinfo3
-rw-r--r--devel/p5-Exception-Class-TryCatch/pkg-descr4
-rw-r--r--devel/p5-Exception-Class-TryCatch/pkg-plist4
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Exception-Class-TryCatch/Makefile b/devel/p5-Exception-Class-TryCatch/Makefile
new file mode 100644
index 000000000000..c47623f826a3
--- /dev/null
+++ b/devel/p5-Exception-Class-TryCatch/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Exception-Class-TryCatch
+# Date created: 2008-02-14
+# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Exception-Class-TryCatch
+PORTVERSION= 1.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lippemail@gmail.com
+COMMENT= Syntactic try/catch sugar for use with Exception::Class
+
+BUILD_DEPENDS+= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Exception::Class::TryCatch.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Exception-Class-TryCatch/distinfo b/devel/p5-Exception-Class-TryCatch/distinfo
new file mode 100644
index 000000000000..28c2a0e954a7
--- /dev/null
+++ b/devel/p5-Exception-Class-TryCatch/distinfo
@@ -0,0 +1,3 @@
+MD5 (Exception-Class-TryCatch-1.10.tar.gz) = e77f27aff6e6b6845944bb677127fd79
+SHA256 (Exception-Class-TryCatch-1.10.tar.gz) = c03d99facb6c377db74576dca2ed6837e210300cc44658773d492cff7f4220ce
+SIZE (Exception-Class-TryCatch-1.10.tar.gz) = 15518
diff --git a/devel/p5-Exception-Class-TryCatch/pkg-descr b/devel/p5-Exception-Class-TryCatch/pkg-descr
new file mode 100644
index 000000000000..08061846c4f6
--- /dev/null
+++ b/devel/p5-Exception-Class-TryCatch/pkg-descr
@@ -0,0 +1,4 @@
+Exception::Class::TryCatch - Syntactic try/catch sugar for use with
+Exception::Class.
+
+WWW: http://search.cpan.org/dist/Exception-Class-TryCatch/
diff --git a/devel/p5-Exception-Class-TryCatch/pkg-plist b/devel/p5-Exception-Class-TryCatch/pkg-plist
new file mode 100644
index 000000000000..f034ae0156bb
--- /dev/null
+++ b/devel/p5-Exception-Class-TryCatch/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Exception/Class/TryCatch/.packlist
+%%SITE_PERL%%/Exception/Class/TryCatch.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Exception/Class/TryCatch
+@dirrmtry %%SITE_PERL%%/Exception/Class