aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Attributes
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-04-03 14:26:06 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-04-03 14:26:06 +0000
commitafdc58fdfa7cfb7ba791c4747f9b782801618b42 (patch)
tree675abf69352e02e7fa1f6a05dc6f2e4a4bfae8fe /devel/p5-File-Attributes
parent9479df838aaa2851a0c7e81a8ce7d5a427dca033 (diff)
Notes
Diffstat (limited to 'devel/p5-File-Attributes')
-rw-r--r--devel/p5-File-Attributes/Makefile37
-rw-r--r--devel/p5-File-Attributes/distinfo3
-rw-r--r--devel/p5-File-Attributes/pkg-descr4
-rw-r--r--devel/p5-File-Attributes/pkg-plist8
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/p5-File-Attributes/Makefile b/devel/p5-File-Attributes/Makefile
new file mode 100644
index 000000000000..c3e7c84faf9d
--- /dev/null
+++ b/devel/p5-File-Attributes/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: devel/p5-File-Attributes
+# Date created: 03 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Attributes
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= File::Attributes - Manipulate file metadata
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Directory/Scratch.pm:${PORTSDIR}/devel/p5-Directory-Scratch \
+ ${SITE_PERL}/Best.pm:${PORTSDIR}/devel/p5-Best \
+ p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Attributes.3 \
+ File::Attributes::Base.3 \
+ File::Attributes::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= fails its tests on this version of perl
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Attributes/distinfo b/devel/p5-File-Attributes/distinfo
new file mode 100644
index 000000000000..1c855c1720b4
--- /dev/null
+++ b/devel/p5-File-Attributes/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Attributes-0.04.tar.gz) = 84e99bff9231a678c6d6e830ca87a6d7
+SHA256 (File-Attributes-0.04.tar.gz) = 1549e05ea0b7daab97219343186820eb07bcb60fa2f675f23189903895f14611
+SIZE (File-Attributes-0.04.tar.gz) = 30374
diff --git a/devel/p5-File-Attributes/pkg-descr b/devel/p5-File-Attributes/pkg-descr
new file mode 100644
index 000000000000..daea2b916157
--- /dev/null
+++ b/devel/p5-File-Attributes/pkg-descr
@@ -0,0 +1,4 @@
+File::Attributes lets you assign attributes to files (and read them, and
+list them, and delete them).
+
+WWW: http://search.cpan.org/dist/File-Attributes/
diff --git a/devel/p5-File-Attributes/pkg-plist b/devel/p5-File-Attributes/pkg-plist
new file mode 100644
index 000000000000..598b18ee990a
--- /dev/null
+++ b/devel/p5-File-Attributes/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/File/Attributes.pm
+%%SITE_PERL%%/File/Attributes/Base.pm
+%%SITE_PERL%%/File/Attributes/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Attributes/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Attributes
+@dirrmtry %%SITE_PERL%%/File/Attributes
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File