aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Cache
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-05-09 01:20:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-05-09 01:20:36 +0000
commit867c78fefae915594921b48e37ea703f28bd7ebf (patch)
treeeb8e7b2ff0574d096f1cd22b3751395437e950e4 /devel/p5-File-Cache
parent0d7fc5659e067ef6b9b4622f3ce4afe3b65b33d7 (diff)
iconditionalize dependencies on modules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. These patches only include unmaintained ports. PR: ports/50589 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=80498
Diffstat (limited to 'devel/p5-File-Cache')
-rw-r--r--devel/p5-File-Cache/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/p5-File-Cache/Makefile b/devel/p5-File-Cache/Makefile
index 2b75987885b5..ffb2b78c1feb 100644
--- a/devel/p5-File-Cache/Makefile
+++ b/devel/p5-File-Cache/Makefile
@@ -15,14 +15,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module implementing a persistent object store
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= File::Cache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>