aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-ExtAttr
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2007-06-21 12:36:16 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2007-06-21 12:36:16 +0000
commitb2fb797cb1d4950bf8627e74d36d246cc49fe7b0 (patch)
treee5413486c5a47a923440714d136e891dd739515e /devel/p5-File-ExtAttr
parentd39bba8d0fdea7837ddd0d8f3245c699daee7053 (diff)
downloadports-b2fb797cb1d4950bf8627e74d36d246cc49fe7b0.tar.gz
ports-b2fb797cb1d4950bf8627e74d36d246cc49fe7b0.zip
Notes
Diffstat (limited to 'devel/p5-File-ExtAttr')
-rw-r--r--devel/p5-File-ExtAttr/Makefile32
-rw-r--r--devel/p5-File-ExtAttr/distinfo3
-rw-r--r--devel/p5-File-ExtAttr/pkg-descr10
-rw-r--r--devel/p5-File-ExtAttr/pkg-plist10
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-File-ExtAttr/Makefile b/devel/p5-File-ExtAttr/Makefile
new file mode 100644
index 000000000000..4193762a76fa
--- /dev/null
+++ b/devel/p5-File-ExtAttr/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: devel/p5-File-ExtAttr
+# Date created: 01 June 2007
+# Whom: Timur Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ExtAttr
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= timur@FreeBSD.org
+COMMENT= Access to extended attributes of the files
+
+PERL_CONFIGURE= yes
+
+MAN3= File::ExtAttr.3 File::ExtAttr::Tie.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= needs Perl 5.8 or later
+.endif
+
+.if ${OSVERSION} < 500018
+IGNORE= extended attributes require FreeBSD 5.x at least after 20010326
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-ExtAttr/distinfo b/devel/p5-File-ExtAttr/distinfo
new file mode 100644
index 000000000000..95b5b2910bc8
--- /dev/null
+++ b/devel/p5-File-ExtAttr/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-ExtAttr-1.04.tar.gz) = adb6253529493f3c568e8fa8c781650e
+SHA256 (File-ExtAttr-1.04.tar.gz) = 5645b932bb00e8216aa9bf5d2bcd5103e634da12b7062c53ef28a9cd4e42d0ae
+SIZE (File-ExtAttr-1.04.tar.gz) = 31493
diff --git a/devel/p5-File-ExtAttr/pkg-descr b/devel/p5-File-ExtAttr/pkg-descr
new file mode 100644
index 000000000000..b7e452631578
--- /dev/null
+++ b/devel/p5-File-ExtAttr/pkg-descr
@@ -0,0 +1,10 @@
+File::ExtAttr is a Perl module providing access to the extended
+attributes of the files.
+
+Extended attributes are metadata associated with a file. Examples are
+access control lists (ACLs) and other security parameters. But users can
+add their own key=value pairs.
+
+Extended attributes are supported by FreeBSD starting from version 5.
+
+WWW: http://search.cpan.org/dist/File-ExtAttr/
diff --git a/devel/p5-File-ExtAttr/pkg-plist b/devel/p5-File-ExtAttr/pkg-plist
new file mode 100644
index 000000000000..55b82de42cae
--- /dev/null
+++ b/devel/p5-File-ExtAttr/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/File/ExtAttr.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/File/ExtAttr/Tie.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ExtAttr/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ExtAttr/ExtAttr.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ExtAttr/ExtAttr.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ExtAttr/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ExtAttr
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/File/ExtAttr
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/File