aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Find-Object
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-15 02:08:26 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-15 02:08:26 +0000
commit4d095e7b5da869d20cb7ae3727a698162953f770 (patch)
tree8630ce5086a496817e6b49203a2498fee0dc713c /devel/p5-File-Find-Object
parentb07cc9815904bab63c08cd1852819e66a93bb536 (diff)
downloadports-4d095e7b5da869d20cb7ae3727a698162953f770.tar.gz
ports-4d095e7b5da869d20cb7ae3727a698162953f770.zip
Notes
Diffstat (limited to 'devel/p5-File-Find-Object')
-rw-r--r--devel/p5-File-Find-Object/Makefile28
-rw-r--r--devel/p5-File-Find-Object/distinfo3
-rw-r--r--devel/p5-File-Find-Object/pkg-descr11
-rw-r--r--devel/p5-File-Find-Object/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/p5-File-Find-Object/Makefile b/devel/p5-File-Find-Object/Makefile
new file mode 100644
index 000000000000..7aea3154736b
--- /dev/null
+++ b/devel/p5-File-Find-Object/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-File-Find-Object
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Find-Object
+PORTVERSION= 0.0.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= An object oriented File::Find replacement
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Find::Object.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Find-Object/distinfo b/devel/p5-File-Find-Object/distinfo
new file mode 100644
index 000000000000..b90393ebfcca
--- /dev/null
+++ b/devel/p5-File-Find-Object/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Find-Object-0.0.3.tar.gz) = ab82a462226eaef4296bdb4306846231
+SHA256 (File-Find-Object-0.0.3.tar.gz) = d284d131fb1e2ff5c6b2b458399b57c7058cf7938f9b553da7e00ce89e67c6b5
+SIZE (File-Find-Object-0.0.3.tar.gz) = 6595
diff --git a/devel/p5-File-Find-Object/pkg-descr b/devel/p5-File-Find-Object/pkg-descr
new file mode 100644
index 000000000000..b350a58c344a
--- /dev/null
+++ b/devel/p5-File-Find-Object/pkg-descr
@@ -0,0 +1,11 @@
+File::Find::Object does same job as File::Find but works like an
+object and with an iterator. As File::Find is not object oriented, one
+cannot perform multiple searches in the same application. The second
+problem of File::Find is its file processing: after starting its main
+loop, one cannot easilly wait for another event an so get the next
+result.
+
+With File::Find::Object you can get the next file by calling the
+next() function, but setting a callback is still possible.
+
+WWW: http://search.cpan.org/dist/File-Find-Object/
diff --git a/devel/p5-File-Find-Object/pkg-plist b/devel/p5-File-Find-Object/pkg-plist
new file mode 100644
index 000000000000..0900cc25a13d
--- /dev/null
+++ b/devel/p5-File-Find-Object/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find/Object/.packlist
+%%SITE_PERL%%/File/Find/Object.pm
+%%SITE_PERL%%/File/Find/Object/internal.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File/Find/Object
+@dirrmtry %%SITE_PERL%%/File/Find
+@dirrmtry %%SITE_PERL%%/File