aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-HStore
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-09-05 01:32:59 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-09-05 01:32:59 +0000
commit919f3f39bc1ae92d5a88025f08364d5239c74f91 (patch)
tree4a88c7ca3f0ff487b21f726bc801afb71b077a1a /devel/p5-File-HStore
parent60d55604b2af617e4dfae7bde10bc2ac1c5fde78 (diff)
downloadports-919f3f39bc1ae92d5a88025f08364d5239c74f91.tar.gz
ports-919f3f39bc1ae92d5a88025f08364d5239c74f91.zip
Notes
Diffstat (limited to 'devel/p5-File-HStore')
-rw-r--r--devel/p5-File-HStore/Makefile10
-rw-r--r--devel/p5-File-HStore/files/patch-HStore.pm61
-rw-r--r--devel/p5-File-HStore/files/patch-Makefile.PL12
3 files changed, 79 insertions, 4 deletions
diff --git a/devel/p5-File-HStore/Makefile b/devel/p5-File-HStore/Makefile
index 58e702c2bd07..4ba93fe1faec 100644
--- a/devel/p5-File-HStore/Makefile
+++ b/devel/p5-File-HStore/Makefile
@@ -7,21 +7,23 @@
PORTNAME= File-HStore
PORTVERSION= 0.09
+PORTREVISION= 1
CATEGORIES= devel perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../../authors/id/A/AD/ADULAU
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Store files on a filesystem using a very simple hash-based storage
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA2.pm:${PORTSDIR}/security/p5-Digest-SHA2
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA
PERL_CONFIGURE= yes
MAN3= File::HStore.3
+post-patch:
+ @${RM} ${WRKSRC}/lib/File/HStore.pm.orig
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
diff --git a/devel/p5-File-HStore/files/patch-HStore.pm b/devel/p5-File-HStore/files/patch-HStore.pm
new file mode 100644
index 000000000000..91c65aa7eb92
--- /dev/null
+++ b/devel/p5-File-HStore/files/patch-HStore.pm
@@ -0,0 +1,61 @@
+--- ../File-HStore-0.09-original/lib/File/HStore.pm Sun Nov 26 11:43:50 2006
++++ lib/File/HStore.pm Tue Jul 17 18:24:13 2007
+@@ -2,8 +2,7 @@
+
+ use strict;
+ use warnings;
+-use Digest::SHA1;
+-use Digest::SHA2;
++use Digest::SHA;
+ use File::Copy;
+ use File::Path;
+
+@@ -69,7 +68,7 @@
+ my $lSubmitDate;
+
+ if ( $self->{digest} eq "FAT" ) {
+- $ldigest = "SHA2";
++ $ldigest = "sha256";
+ }
+ else {
+ $ldigest = $self->{digest};
+@@ -191,10 +190,10 @@
+ my $sha;
+ open( FILED, "$file" ) or die "Unable to open file $file";
+ if ( $digestdef eq "SHA1" ) {
+- $sha = Digest::SHA1->new;
++ $sha = Digest::SHA->new("sha1");
+ }
+ elsif ( $digestdef eq "SHA2" ) {
+- $sha = Digest::SHA2->new;
++ $sha = Digest::SHA->new("sha256");
+ }
+ else {
+ print "unknown digest method";
+@@ -242,7 +241,7 @@
+
+ use File::HStore;
+ my $store = File::HStore ("/tmp/.mystore");
+-
++
+ # Add a file in the store
+ my $id = $store->add("/foo/bar.txt");
+
+@@ -272,7 +271,7 @@
+ =head1 METHODS
+
+ The object oriented interface to C<File::HFile> is described in this
+-section.
++section.
+
+ The following methods are provided:
+
+@@ -302,7 +301,7 @@
+
+ =item $store->remove($hashvalue)
+
+-The $hashvalue is the file to be removed from the store.
++The $hashvalue is the file to be removed from the store.
+
+ Return false on success and undef on error.
+
diff --git a/devel/p5-File-HStore/files/patch-Makefile.PL b/devel/p5-File-HStore/files/patch-Makefile.PL
new file mode 100644
index 000000000000..a72f00db37f6
--- /dev/null
+++ b/devel/p5-File-HStore/files/patch-Makefile.PL
@@ -0,0 +1,12 @@
+--- ../File-HStore-0.09-original/Makefile.PL Sun Nov 26 11:05:53 2006
++++ Makefile.PL Tue Jul 17 18:08:11 2007
+@@ -5,8 +5,7 @@
+ WriteMakefile(
+ NAME => 'File::HStore',
+ VERSION_FROM => 'lib/File/HStore.pm', # finds $VERSION
+- PREREQ_PM => { 'Digest::SHA1' => '0',
+- 'Digest::SHA2' => '0',
++ PREREQ_PM => { 'Digest::SHA' => '0',
+ 'File::Copy' => '0',
+ 'Test::More' => '0',
+ 'File::Path' => '0' }, # e.g., Module::Name => 1.1