aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-MMagic-XS
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-18 17:34:23 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-18 17:34:23 +0000
commitaabd7239f7152d8b1811efdf74e1e2246c9db42e (patch)
tree73acca9bfa9e89b64ae6ca7314e83986e7402418 /devel/p5-File-MMagic-XS
parenta80a5566ac74a8aa59c9c0e19ef284256213b3f8 (diff)
downloadports-aabd7239f7152d8b1811efdf74e1e2246c9db42e.tar.gz
ports-aabd7239f7152d8b1811efdf74e1e2246c9db42e.zip
Notes
Diffstat (limited to 'devel/p5-File-MMagic-XS')
-rw-r--r--devel/p5-File-MMagic-XS/Makefile28
-rw-r--r--devel/p5-File-MMagic-XS/distinfo3
-rw-r--r--devel/p5-File-MMagic-XS/pkg-descr23
-rw-r--r--devel/p5-File-MMagic-XS/pkg-plist12
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/p5-File-MMagic-XS/Makefile b/devel/p5-File-MMagic-XS/Makefile
new file mode 100644
index 000000000000..fc379ddb9a6c
--- /dev/null
+++ b/devel/p5-File-MMagic-XS/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-File-MMagic-XS
+# Date created: 18 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-MMagic-XS
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Guess File Type With XS (a la mod_mime_magic)
+
+MAN3= File::MMagic::XS.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-MMagic-XS/distinfo b/devel/p5-File-MMagic-XS/distinfo
new file mode 100644
index 000000000000..a1bcd6b10728
--- /dev/null
+++ b/devel/p5-File-MMagic-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-MMagic-XS-0.08.tar.gz) = b8ce9617527a999c85d54fc8a4e88ebc
+SHA256 (File-MMagic-XS-0.08.tar.gz) = 40ce6a8a6229e861fb8deefe2f82a3a529968c75e58b04d7388fe7a2d6c92bc2
+SIZE (File-MMagic-XS-0.08.tar.gz) = 54434
diff --git a/devel/p5-File-MMagic-XS/pkg-descr b/devel/p5-File-MMagic-XS/pkg-descr
new file mode 100644
index 000000000000..6091aa05b266
--- /dev/null
+++ b/devel/p5-File-MMagic-XS/pkg-descr
@@ -0,0 +1,23 @@
+This is a port of Apache2 mod_mime_magic.c in Perl, written in XS with the
+aim of being efficient and fast especially for applications that need to
+be run for an extended amount of time.
+
+There is a compatibility layer for File::MMagic. you can specify :compat
+when importing the module
+
+ use File::MMagic::XS qw(:compat);
+
+And then the following methods are going to be available from
+File::MMagic::XS:
+
+ checktype_filename
+ checktype_filehandle
+ checktype_contents
+ addMagicEntry
+
+Currently this software is in beta. If you have
+suggestions/recommendations about the interface or anything else, now is
+your chance to send them!
+
+WWW: http://search.cpan.org/dist/File-MMagic-XS
+Author: Daisuke Maki <dmaki@cpan.org>
diff --git a/devel/p5-File-MMagic-XS/pkg-plist b/devel/p5-File-MMagic-XS/pkg-plist
new file mode 100644
index 000000000000..d61502bf0018
--- /dev/null
+++ b/devel/p5-File-MMagic-XS/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/File/MMagic/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/File/MMagic/benchmark.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/File/MMagic/compat.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/File/MMagic/magic
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/MMagic/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/MMagic/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/MMagic/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/MMagic/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/MMagic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/File/MMagic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/File