aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Filter-CBC/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-02 12:48:09 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-02 12:48:09 +0000
commit3e00f6c24d9fed87ff284013bb06c95c67428a6f (patch)
treed444ba31488b44889ddc53de7f429c23a30ec4ce /devel/p5-Filter-CBC/Makefile
parent65db0e673bf00a3b9dfd980bccc8f39485a1125a (diff)
Notes
Diffstat (limited to 'devel/p5-Filter-CBC/Makefile')
-rw-r--r--devel/p5-Filter-CBC/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/p5-Filter-CBC/Makefile b/devel/p5-Filter-CBC/Makefile
index d979f9603526..a34527ad657e 100644
--- a/devel/p5-Filter-CBC/Makefile
+++ b/devel/p5-Filter-CBC/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= Filter-CBC
-PORTVERSION= 0.07
+PORTVERSION= 0.09
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Filter
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
@@ -20,14 +20,16 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Filter/
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Filter::CBC.3
post-install:
.ifndef(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>