aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Prompt-Tiny
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-01-30 16:39:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-01-30 16:39:57 +0000
commitb90f1d112b0045f6ae440b4e1b3df708182cb96e (patch)
tree38933158e80a32d57abce447e8aa505a79f6510d /devel/p5-IO-Prompt-Tiny
parent67b18cfb1f5bd86fe4b962536f1237d436bc0452 (diff)
downloadports-b90f1d112b0045f6ae440b4e1b3df708182cb96e.tar.gz
ports-b90f1d112b0045f6ae440b4e1b3df708182cb96e.zip
Notes
Diffstat (limited to 'devel/p5-IO-Prompt-Tiny')
-rw-r--r--devel/p5-IO-Prompt-Tiny/Makefile28
-rw-r--r--devel/p5-IO-Prompt-Tiny/distinfo2
-rw-r--r--devel/p5-IO-Prompt-Tiny/pkg-descr10
-rw-r--r--devel/p5-IO-Prompt-Tiny/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-IO-Prompt-Tiny/Makefile b/devel/p5-IO-Prompt-Tiny/Makefile
new file mode 100644
index 000000000000..f21b50590661
--- /dev/null
+++ b/devel/p5-IO-Prompt-Tiny/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= IO-Prompt-Tiny
+PORTVERSION= 0.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Prompt for user input with a default option
+
+LICENSE= AL2
+
+BUILD_DEPENDS= p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Prompt::Tiny.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-Prompt-Tiny/distinfo b/devel/p5-IO-Prompt-Tiny/distinfo
new file mode 100644
index 000000000000..42212681ddea
--- /dev/null
+++ b/devel/p5-IO-Prompt-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-Prompt-Tiny-0.001.tar.gz) = e0b0fda99b3319c168a57b1dba5517152491e3da687077bf6844b3d716b30648
+SIZE (IO-Prompt-Tiny-0.001.tar.gz) = 11411
diff --git a/devel/p5-IO-Prompt-Tiny/pkg-descr b/devel/p5-IO-Prompt-Tiny/pkg-descr
new file mode 100644
index 000000000000..e886f919cfe9
--- /dev/null
+++ b/devel/p5-IO-Prompt-Tiny/pkg-descr
@@ -0,0 +1,10 @@
+IO::Prompt::Tiny is an extremely simple prompting module, based on the extremely
+simple prompt offered by ExtUtils::MakeMaker.In many cases, that's all you need
+and this module gives it to you without all the overhead of ExtUtils::MakeMaker
+just to prompt for input.
+
+It doesn't do any validation, coloring, menus, timeouts, or any of the wild,
+crazy, cool stuff that other prompting modules do. It just prompts with a
+default. That's it!
+
+WWW: http://search.cpan.org/dist/IO-Prompt-Tiny/
diff --git a/devel/p5-IO-Prompt-Tiny/pkg-plist b/devel/p5-IO-Prompt-Tiny/pkg-plist
new file mode 100644
index 000000000000..ac9452d11bb8
--- /dev/null
+++ b/devel/p5-IO-Prompt-Tiny/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/IO/Prompt/Tiny.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Prompt/Tiny/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Prompt/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Prompt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
+@dirrmtry %%SITE_PERL%%/IO/Prompt
+@dirrmtry %%SITE_PERL%%/IO