aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Toolkit/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 15:26:25 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-14 15:26:25 +0000
commitaf196b5e40f0394098a2c5a2ef0b338d2e65c6d4 (patch)
treebcc18773ffc40f141a92c8514269b8688577b37a /devel/p5-IO-Toolkit/Makefile
parent9ecad3676fd169d63cd6116b5f3ae496b29ab19c (diff)
downloadports-af196b5e40f0394098a2c5a2ef0b338d2e65c6d4.tar.gz
ports-af196b5e40f0394098a2c5a2ef0b338d2e65c6d4.zip
Notes
Diffstat (limited to 'devel/p5-IO-Toolkit/Makefile')
-rw-r--r--devel/p5-IO-Toolkit/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-IO-Toolkit/Makefile b/devel/p5-IO-Toolkit/Makefile
new file mode 100644
index 000000000000..19d1f20610e7
--- /dev/null
+++ b/devel/p5-IO-Toolkit/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-IO-Toolkit
+# Date created: 2006-07-12
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Toolkit
+PORTVERSION= 1.008
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.org
+COMMENT= IO::Toolkit - Perl extension to create logfiles
+
+BUILD_DEPENDS= p5-Crypt-RC6>=0:${PORTSDIR}/security/p5-Crypt-RC6 \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Toolkit.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= currently requires at least Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>