aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Extract/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:55 +0000
commitfebc6fb0097f693da426c570054f23c344c81588 (patch)
tree7097c194f5d304d452abd6594ca9a08db8bd8e95 /devel/p5-Module-Extract/Makefile
parent2c31fcf4a25df2f06df31810b0c93d54d00ad786 (diff)
downloadports-febc6fb0097f693da426c570054f23c344c81588.tar.gz
ports-febc6fb0097f693da426c570054f23c344c81588.zip
Notes
Diffstat (limited to 'devel/p5-Module-Extract/Makefile')
-rw-r--r--devel/p5-Module-Extract/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/p5-Module-Extract/Makefile b/devel/p5-Module-Extract/Makefile
new file mode 100644
index 000000000000..d98ef22e6cea
--- /dev/null
+++ b/devel/p5-Module-Extract/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Module-Extract
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Extract
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Base class for working with Perl distributions
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Extract.pm:${PORTSDIR}/archivers/p5-Archive-Extract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Module::Extract.3
+
+.include <bsd.port.mk>