aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-SetOnce
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-03 12:04:17 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-03 12:04:17 +0000
commit775f103325057c316056326fa3c22b1c8db08832 (patch)
tree5996bee97216549c54d175fe3273bba1964be8ea /devel/p5-MooseX-SetOnce
parente0e7be45f7e55f7a4814c030d6a9486029c7cebb (diff)
The 'SetOnce' attribute lets your class have attributes that are not lazy and
not set, but that cannot be altered once set. If you try to alter the value of an attribute with the SetOnce trait, either by accessor or writer, and the attribute has a value, it will throw an exception. WWW: http://search.cpan.org/dist/MooseX-SetOnce/ This new port is needed to update www/p5-HTML-FormFu.
Notes
Notes: svn path=/head/; revision=272148
Diffstat (limited to 'devel/p5-MooseX-SetOnce')
-rw-r--r--devel/p5-MooseX-SetOnce/Makefile26
-rw-r--r--devel/p5-MooseX-SetOnce/distinfo2
-rw-r--r--devel/p5-MooseX-SetOnce/pkg-descr6
-rw-r--r--devel/p5-MooseX-SetOnce/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-MooseX-SetOnce/Makefile b/devel/p5-MooseX-SetOnce/Makefile
new file mode 100644
index 000000000000..6d4c8d2e4649
--- /dev/null
+++ b/devel/p5-MooseX-SetOnce/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: MooseX-SetOnce
+# Date created: 2011-04-03
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-SetOnce
+PORTVERSION= 0.100473
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RJBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Write-once, read-many attributes for Moose
+
+RUN_DEPENDS= p5-Moose>=0.90:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS= p5-Test-Fatal>=0:{PORTSDIR}/devel/p5-Test-Fatal
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::SetOnce.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-SetOnce/distinfo b/devel/p5-MooseX-SetOnce/distinfo
new file mode 100644
index 000000000000..1b03424dd9e4
--- /dev/null
+++ b/devel/p5-MooseX-SetOnce/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooseX-SetOnce-0.100473.tar.gz) = 543c304febd2be7b03b0bed7e7bfb3930a0cbab6175031d1c6242733f0c9e61b
+SIZE (MooseX-SetOnce-0.100473.tar.gz) = 10845
diff --git a/devel/p5-MooseX-SetOnce/pkg-descr b/devel/p5-MooseX-SetOnce/pkg-descr
new file mode 100644
index 000000000000..c09d70a2d819
--- /dev/null
+++ b/devel/p5-MooseX-SetOnce/pkg-descr
@@ -0,0 +1,6 @@
+The 'SetOnce' attribute lets your class have attributes that are not lazy and
+not set, but that cannot be altered once set. If you try to alter the value
+of an attribute with the SetOnce trait, either by accessor or writer, and the
+attribute has a value, it will throw an exception.
+
+WWW: http://search.cpan.org/dist/MooseX-SetOnce/
diff --git a/devel/p5-MooseX-SetOnce/pkg-plist b/devel/p5-MooseX-SetOnce/pkg-plist
new file mode 100644
index 000000000000..6016661c7c97
--- /dev/null
+++ b/devel/p5-MooseX-SetOnce/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/SetOnce/.packlist
+%%SITE_PERL%%/MooseX/SetOnce.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/SetOnce
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX