aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-Component-RSS
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 11:36:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 11:36:25 +0000
commit1018ce2b4c8cee7831c302f3f561238ee65008b1 (patch)
treef3f397a2dbe9f10d32892166db011a00452ffb55 /devel/p5-POE-Component-RSS
parentc3c940542393ea373cb20b6755d41b57c7fafd4c (diff)
add p5-POE-Component-RSS
A module for event based RSS parsing PR: 32776 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=51475
Diffstat (limited to 'devel/p5-POE-Component-RSS')
-rw-r--r--devel/p5-POE-Component-RSS/Makefile26
-rw-r--r--devel/p5-POE-Component-RSS/distinfo1
-rw-r--r--devel/p5-POE-Component-RSS/pkg-comment1
-rw-r--r--devel/p5-POE-Component-RSS/pkg-descr8
-rw-r--r--devel/p5-POE-Component-RSS/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-POE-Component-RSS/Makefile b/devel/p5-POE-Component-RSS/Makefile
new file mode 100644
index 000000000000..41ba80514566
--- /dev/null
+++ b/devel/p5-POE-Component-RSS/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Component-RSS
+# Date created: 10 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-RSS
+PORTVERSION= 0.06
+CATEGORIES= devel perl5 textproc
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::RSS.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-RSS/distinfo b/devel/p5-POE-Component-RSS/distinfo
new file mode 100644
index 000000000000..b87f7b88f088
--- /dev/null
+++ b/devel/p5-POE-Component-RSS/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-RSS-0.06.tar.gz) = e7d033733149102d2ae4f718c29449ce
diff --git a/devel/p5-POE-Component-RSS/pkg-comment b/devel/p5-POE-Component-RSS/pkg-comment
new file mode 100644
index 000000000000..82ad9b32517e
--- /dev/null
+++ b/devel/p5-POE-Component-RSS/pkg-comment
@@ -0,0 +1 @@
+A module for event based RSS parsing
diff --git a/devel/p5-POE-Component-RSS/pkg-descr b/devel/p5-POE-Component-RSS/pkg-descr
new file mode 100644
index 000000000000..d2f69547bcc2
--- /dev/null
+++ b/devel/p5-POE-Component-RSS/pkg-descr
@@ -0,0 +1,8 @@
+POE::Component::RSS is an event based RSS parsing module. It wraps
+XML::RSS and provides a POE based framework for accessing the information
+provided.
+
+WWW: http://search.cpan.org/search?dist=POE-Component-RSS
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/devel/p5-POE-Component-RSS/pkg-plist b/devel/p5-POE-Component-RSS/pkg-plist
new file mode 100644
index 000000000000..bbfa21127983
--- /dev/null
+++ b/devel/p5-POE-Component-RSS/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/RSS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/RSS.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/RSS
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true