aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-PathTools
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>2000-11-23 05:02:14 +0000
committerDonald Burr <dburr@FreeBSD.org>2000-11-23 05:02:14 +0000
commitfb6006943e8855a2910201c01ce4fda9d812645f (patch)
tree162d8e4103d86b120b48a6fe7a6377c0298bd387 /devel/p5-PathTools
parent1232f4bf0656ca38fcd78ad0ad287f7888fb2b3c (diff)
downloadports-fb6006943e8855a2910201c01ce4fda9d812645f.tar.gz
ports-fb6006943e8855a2910201c01ce4fda9d812645f.zip
Notes
Diffstat (limited to 'devel/p5-PathTools')
-rw-r--r--devel/p5-PathTools/Makefile32
-rw-r--r--devel/p5-PathTools/distinfo1
-rw-r--r--devel/p5-PathTools/pkg-comment1
-rw-r--r--devel/p5-PathTools/pkg-descr9
-rw-r--r--devel/p5-PathTools/pkg-plist11
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-PathTools/Makefile b/devel/p5-PathTools/Makefile
new file mode 100644
index 000000000000..749661f8165d
--- /dev/null
+++ b/devel/p5-PathTools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-File-Spec
+# Date created: November 22, 2000
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+USE_PERL5= yes
+
+MAN3= File::Spec.3 \
+ File::Spec::Functions.3 \
+ File::Spec::Mac.3 \
+ File::Spec::OS2.3 \
+ File::Spec::Unix.3 \
+ File::Spec::VMS.3 \
+ File::Spec::Win32.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/devel/p5-PathTools/distinfo b/devel/p5-PathTools/distinfo
new file mode 100644
index 000000000000..0cfacdea31fa
--- /dev/null
+++ b/devel/p5-PathTools/distinfo
@@ -0,0 +1 @@
+MD5 (File-Spec-0.8.tar.gz) = 835c7d14e6c373fd8440539cc479badf
diff --git a/devel/p5-PathTools/pkg-comment b/devel/p5-PathTools/pkg-comment
new file mode 100644
index 000000000000..a945e920b6e8
--- /dev/null
+++ b/devel/p5-PathTools/pkg-comment
@@ -0,0 +1 @@
+A Perl module for portably manipulating file specifications
diff --git a/devel/p5-PathTools/pkg-descr b/devel/p5-PathTools/pkg-descr
new file mode 100644
index 000000000000..c6b391dddffe
--- /dev/null
+++ b/devel/p5-PathTools/pkg-descr
@@ -0,0 +1,9 @@
+This module is designed to support operations commonly
+performed on file specifications (usually called "file
+names", but not to be confused with the contents of a
+file, or Perl's file handles), such as concatenating
+several directory and file names into a single path, or
+determining whether a path is rooted. It is based on code
+directly taken from MakeMaker 5.17, code written by
+Andreas Koenig, Andy Dougherty, Charles Bailey, Ilya
+Zakharevich, Paul Schinder, and others.
diff --git a/devel/p5-PathTools/pkg-plist b/devel/p5-PathTools/pkg-plist
new file mode 100644
index 000000000000..24b9babfb668
--- /dev/null
+++ b/devel/p5-PathTools/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Functions.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/OS2.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/VMS.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/File/Spec
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/File