aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ReadLine-Gnu
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /devel/p5-ReadLine-Gnu
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Notes
Diffstat (limited to 'devel/p5-ReadLine-Gnu')
-rw-r--r--devel/p5-ReadLine-Gnu/Makefile8
-rw-r--r--devel/p5-ReadLine-Gnu/files/patch-aa11
2 files changed, 16 insertions, 3 deletions
diff --git a/devel/p5-ReadLine-Gnu/Makefile b/devel/p5-ReadLine-Gnu/Makefile
index 4b6e756c63f1..22346eb83dc3 100644
--- a/devel/p5-ReadLine-Gnu/Makefile
+++ b/devel/p5-ReadLine-Gnu/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Term
PKGNAMEPREFIX= p5-
-DISTNAME= Term-ReadLine-Gnu-${PORTVERSION}
+DISTNAME= Term-${PORTNAME}-${PORTVERSION}
MAINTAINER= mph@freebsd.org
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= Term::ReadLine::Gnu.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -24,6 +24,8 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
# automatically. There is sometimes an old libreadline in /usr/local/lib
# and this module won't work with it.
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL LDDLFLAGS=-shared LDFLAGS=-L/usr/lib
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}" \
+ LDDLFLAGS=-shared LDFLAGS=-L/usr/lib
.include <bsd.port.mk>
diff --git a/devel/p5-ReadLine-Gnu/files/patch-aa b/devel/p5-ReadLine-Gnu/files/patch-aa
new file mode 100644
index 000000000000..e117ab71ec84
--- /dev/null
+++ b/devel/p5-ReadLine-Gnu/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Mon Jun 12 23:43:42 2000
++++ Makefile.PL Mon Jun 12 23:45:21 2000
+@@ -76,7 +76,7 @@
+ close(F);
+
+ # compile it
+-$comp_cmd = "$Config{cc} $RLINC $Config{ccflags} $defs $frlver -o rlver $RLLIB $Config{ldflags} $libs";
++$comp_cmd = "$Config{cc} $RLINC $Config{ccflags} $defs $frlver -o rlver $RLLIB $libs";
+ print $comp_cmd, "\n";
+ system($comp_cmd);
+ if ($?) {