aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Readonly-XS/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-27 20:45:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-27 20:45:06 +0000
commit91160c383ee7350cca33234738c09ec7458b9e31 (patch)
tree5b6025648deb3f0221d615678690118768caacf5 /devel/p5-Readonly-XS/Makefile
parent8c09dc1258f4595dec285418fa947ba973b7117d (diff)
- Add p5-Readonly-XS 1.05
This module corrects the speed problem, at least with respect to scalar variables. When Readonly::XS is installed, Readonly uses it to access the internals of scalar variables. Instead of creating a scalar variable object and tying it, Readonly simply flips the SvREADONLY bit in the scalar's FLAGS structure. Readonly arrays and hashes are not sped up by this, since the SvREADONLY flag only works for scalars. Arrays and hashes always use the tie interface. Programs that you write do not need to know whether Readonly::XS is installed or not. They should just "use Readonly" and let Readonly worry about whether or not it can use XS. If the Readonly::XS is present, Readonly will be faster. If not, it won't. Either way, it will still work, and your code will not have to change. Your program can check whether Readonly.pm is using XS or not by examining the $Readonly::XSokay variable. It will be true if the XS module was found and is being used. Please do not change this variable. WWW: http://search.cpan.org/dist/Readonly-XS/
Notes
Notes: svn path=/head/; revision=335059
Diffstat (limited to 'devel/p5-Readonly-XS/Makefile')
-rw-r--r--devel/p5-Readonly-XS/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/p5-Readonly-XS/Makefile b/devel/p5-Readonly-XS/Makefile
new file mode 100644
index 000000000000..35e6d77cdb46
--- /dev/null
+++ b/devel/p5-Readonly-XS/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Readonly-XS
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Companion module for Readonly.pm, to speed up read-only scalar variables
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Readonly>=1.02:${PORTSDIR}/devel/p5-Readonly
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>