aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Readonly
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-08-31 11:57:23 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-08-31 11:57:23 +0000
commit69ef7dcc8d74dfb1bb54d546198f3eb7c534e279 (patch)
treea57e134b29e65f80c5c359c1d351bba9e3b47e8b /devel/p5-Readonly
parent341645c901d2a4f6ed3fc80afaeb5bbbbc163081 (diff)
downloadports-69ef7dcc8d74dfb1bb54d546198f3eb7c534e279.tar.gz
ports-69ef7dcc8d74dfb1bb54d546198f3eb7c534e279.zip
Notes
Diffstat (limited to 'devel/p5-Readonly')
-rw-r--r--devel/p5-Readonly/Makefile35
-rw-r--r--devel/p5-Readonly/distinfo4
-rw-r--r--devel/p5-Readonly/pkg-descr6
-rw-r--r--devel/p5-Readonly/pkg-plist8
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/p5-Readonly/Makefile b/devel/p5-Readonly/Makefile
new file mode 100644
index 000000000000..47c9a8312bf4
--- /dev/null
+++ b/devel/p5-Readonly/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Readonly
+# Date created: 31 August 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Readonly
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROODE
+PKGNAMEPREFIX= p5-
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-XS-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Facility for creating read-only scalars, arrays, hashes
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= DIR="${PORTNAME}-XS-${PORTVERSION}"
+
+MAN3= Readonly.3 Readonly::XS.3
+
+post-patch:
+ ${MV} ${WRKDIR}/${PORTNAME}-XS-${PORTVERSION} ${WRKSRC}
+ ${RM} ${WRKSRC}/*.pl
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Readonly/distinfo b/devel/p5-Readonly/distinfo
new file mode 100644
index 000000000000..22fe8ce390a0
--- /dev/null
+++ b/devel/p5-Readonly/distinfo
@@ -0,0 +1,4 @@
+MD5 (Readonly-1.03.tar.gz) = 0acef3a995ac9ecf575f66a726d638f4
+SIZE (Readonly-1.03.tar.gz) = 13677
+MD5 (Readonly-XS-1.03.tar.gz) = 18742d473da99aa6e02261b55e008e3a
+SIZE (Readonly-XS-1.03.tar.gz) = 9032
diff --git a/devel/p5-Readonly/pkg-descr b/devel/p5-Readonly/pkg-descr
new file mode 100644
index 000000000000..2eca807ec9a3
--- /dev/null
+++ b/devel/p5-Readonly/pkg-descr
@@ -0,0 +1,6 @@
+This is a facility for creating non-modifiable variables. This is
+useful for configuration files, headers, etc. It can also be useful as
+a development and debugging tool, for catching updates to variables that
+should not be changed.
+
+WWW: http://search.cpan.org/dist/Readonly/
diff --git a/devel/p5-Readonly/pkg-plist b/devel/p5-Readonly/pkg-plist
new file mode 100644
index 000000000000..591d1bcf6495
--- /dev/null
+++ b/devel/p5-Readonly/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Readonly.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Readonly/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Readonly
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly