aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Term-Animation
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-09-16 05:55:55 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-09-16 05:55:55 +0000
commita6e7ef2ffb53616b5b2cc8861f5ea898f7805cda (patch)
treedb0bac8246d8b118a4a23b76dcacf4c44b612113 /devel/p5-Term-Animation
parent1dbc908d192fdd944d4e497665e8c89131015ca5 (diff)
downloadports-a6e7ef2ffb53616b5b2cc8861f5ea898f7805cda.tar.gz
ports-a6e7ef2ffb53616b5b2cc8861f5ea898f7805cda.zip
Notes
Diffstat (limited to 'devel/p5-Term-Animation')
-rw-r--r--devel/p5-Term-Animation/Makefile25
-rw-r--r--devel/p5-Term-Animation/distinfo2
-rw-r--r--devel/p5-Term-Animation/pkg-descr12
-rw-r--r--devel/p5-Term-Animation/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Term-Animation/Makefile b/devel/p5-Term-Animation/Makefile
new file mode 100644
index 000000000000..8d16a71c2fc1
--- /dev/null
+++ b/devel/p5-Term-Animation/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Term-Animation
+# Date created: Sep 16, 2005
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Animation
+PORTVERSION= 2.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= ASCII sprite animation framework
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Animation.3 Term::Animation::Entity.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-Animation/distinfo b/devel/p5-Term-Animation/distinfo
new file mode 100644
index 000000000000..f3da165e004a
--- /dev/null
+++ b/devel/p5-Term-Animation/distinfo
@@ -0,0 +1,2 @@
+MD5 (Term-Animation-2.1.tar.gz) = 8bfb8225be9318f95e0b1e1718da9691
+SIZE (Term-Animation-2.1.tar.gz) = 17369
diff --git a/devel/p5-Term-Animation/pkg-descr b/devel/p5-Term-Animation/pkg-descr
new file mode 100644
index 000000000000..4fd18be33372
--- /dev/null
+++ b/devel/p5-Term-Animation/pkg-descr
@@ -0,0 +1,12 @@
+This module provides a framework to produce sprite animations using
+ASCII art. Each ASCII 'sprite' is given one or more frames, and placed
+into the animation as an 'animation object'. An animation object can
+have a callback routine that controls the position and frame of the
+object.
+
+If the constructor is passed no arguments, it assumes that it is
+running full screen, and behaves accordingly. Alternatively, it can
+accept a curses window (created with the Curses newwin call) as an
+argument, and will draw into that window.
+
+WWW: http://search.cpan.org/dist/Term-Animation/
diff --git a/devel/p5-Term-Animation/pkg-plist b/devel/p5-Term-Animation/pkg-plist
new file mode 100644
index 000000000000..77961f8bc4f0
--- /dev/null
+++ b/devel/p5-Term-Animation/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Term/Animation.pm
+%%SITE_PERL%%/Term/Animation/Entity.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Animation/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Animation
+@unexec rmdir %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Term/Animation
+@unexec rmdir %%SITE_PERL%%/Term 2>/dev/null || true