aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Deep
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-30 08:42:30 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-30 08:42:30 +0000
commitafc2d33becc76aac62350f46d0cb421438e820f8 (patch)
tree98d09611b9a82879bf286ebe244c8b2054ea7ece /devel/p5-Test-Deep
parent41cb81d2e54206daa6406ccb86b390d09e9f7786 (diff)
downloadports-afc2d33becc76aac62350f46d0cb421438e820f8.tar.gz
ports-afc2d33becc76aac62350f46d0cb421438e820f8.zip
Notes
Diffstat (limited to 'devel/p5-Test-Deep')
-rw-r--r--devel/p5-Test-Deep/Makefile32
-rw-r--r--devel/p5-Test-Deep/distinfo2
-rw-r--r--devel/p5-Test-Deep/pkg-descr8
-rw-r--r--devel/p5-Test-Deep/pkg-plist46
-rw-r--r--devel/p5-Test-Deep/plist38
5 files changed, 126 insertions, 0 deletions
diff --git a/devel/p5-Test-Deep/Makefile b/devel/p5-Test-Deep/Makefile
new file mode 100644
index 000000000000..b54164625ded
--- /dev/null
+++ b/devel/p5-Test-Deep/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Test-Deep
+# Date created: May 12th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Deep
+PORTVERSION= 0.087
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Test data structures for differences deeply
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Test/Tester.pm:${PORTSDIR}/devel/p5-Test-Tester \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Test::Deep.3
+
+post-patch:
+ @${PERL} -i -pe 'm/INSTALLDIRS\s+=>/ and $$_ = ""' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Deep/distinfo b/devel/p5-Test-Deep/distinfo
new file mode 100644
index 000000000000..8cc93f0e0c3f
--- /dev/null
+++ b/devel/p5-Test-Deep/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-Deep-0.087.tar.gz) = 6b0b9de6c540f613f8f3db942d93a467
+SIZE (Test-Deep-0.087.tar.gz) = 29135
diff --git a/devel/p5-Test-Deep/pkg-descr b/devel/p5-Test-Deep/pkg-descr
new file mode 100644
index 000000000000..064a5aa342d0
--- /dev/null
+++ b/devel/p5-Test-Deep/pkg-descr
@@ -0,0 +1,8 @@
+Test::Deep gives you very flexible ways to check that the result you
+got is the result you were expecting. At it's simplest it compares two
+structures by going through each level, ensuring that the values
+match, that arrays and hashes have the same elements and that
+references are blessed into the correct class. It also handles
+circular data struc- tures without getting caught in an infinite loop.
+
+WWW: http://search.cpan.org/dist/Test-Deep/
diff --git a/devel/p5-Test-Deep/pkg-plist b/devel/p5-Test-Deep/pkg-plist
new file mode 100644
index 000000000000..c0f0022bc06e
--- /dev/null
+++ b/devel/p5-Test-Deep/pkg-plist
@@ -0,0 +1,46 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Deep/.packlist
+%%SITE_PERL%%/Test/Deep.pm
+%%SITE_PERL%%/Test/Deep.pod
+%%SITE_PERL%%/Test/Deep/All.pm
+%%SITE_PERL%%/Test/Deep/Any.pm
+%%SITE_PERL%%/Test/Deep/Array.pm
+%%SITE_PERL%%/Test/Deep/ArrayEach.pm
+%%SITE_PERL%%/Test/Deep/ArrayElementsOnly.pm
+%%SITE_PERL%%/Test/Deep/ArrayLength.pm
+%%SITE_PERL%%/Test/Deep/ArrayLengthOnly.pm
+%%SITE_PERL%%/Test/Deep/Blessed.pm
+%%SITE_PERL%%/Test/Deep/Boolean.pm
+%%SITE_PERL%%/Test/Deep/Cache.pm
+%%SITE_PERL%%/Test/Deep/Cache/Simple.pm
+%%SITE_PERL%%/Test/Deep/Class.pm
+%%SITE_PERL%%/Test/Deep/Cmp.pm
+%%SITE_PERL%%/Test/Deep/Code.pm
+%%SITE_PERL%%/Test/Deep/Hash.pm
+%%SITE_PERL%%/Test/Deep/HashEach.pm
+%%SITE_PERL%%/Test/Deep/HashElements.pm
+%%SITE_PERL%%/Test/Deep/HashKeys.pm
+%%SITE_PERL%%/Test/Deep/HashKeysOnly.pm
+%%SITE_PERL%%/Test/Deep/Ignore.pm
+%%SITE_PERL%%/Test/Deep/Isa.pm
+%%SITE_PERL%%/Test/Deep/ListMethods.pm
+%%SITE_PERL%%/Test/Deep/MM.pm
+%%SITE_PERL%%/Test/Deep/Methods.pm
+%%SITE_PERL%%/Test/Deep/Number.pm
+%%SITE_PERL%%/Test/Deep/Ref.pm
+%%SITE_PERL%%/Test/Deep/RefType.pm
+%%SITE_PERL%%/Test/Deep/Regexp.pm
+%%SITE_PERL%%/Test/Deep/RegexpMatches.pm
+%%SITE_PERL%%/Test/Deep/RegexpOnly.pm
+%%SITE_PERL%%/Test/Deep/RegexpRef.pm
+%%SITE_PERL%%/Test/Deep/RegexpRefOnly.pm
+%%SITE_PERL%%/Test/Deep/ScalarRef.pm
+%%SITE_PERL%%/Test/Deep/ScalarRefOnly.pm
+%%SITE_PERL%%/Test/Deep/Set.pm
+%%SITE_PERL%%/Test/Deep/Shallow.pm
+%%SITE_PERL%%/Test/Deep/Stack.pm
+%%SITE_PERL%%/Test/Deep/String.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Deep
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Test/Deep/Cache
+@dirrm %%SITE_PERL%%/Test/Deep
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true
diff --git a/devel/p5-Test-Deep/plist b/devel/p5-Test-Deep/plist
new file mode 100644
index 000000000000..a4f530ae9580
--- /dev/null
+++ b/devel/p5-Test-Deep/plist
@@ -0,0 +1,38 @@
+%%SITE_PERL%%/Test/Deep/String.pm
+%%SITE_PERL%%/Test/Deep/Cmp.pm
+%%SITE_PERL%%/Test/Deep/Boolean.pm
+%%SITE_PERL%%/Test/Deep/HashElements.pm
+%%SITE_PERL%%/Test/Deep/Isa.pm
+%%SITE_PERL%%/Test/Deep/ArrayLengthOnly.pm
+%%SITE_PERL%%/Test/Deep/Cache/Simple.pm
+%%SITE_PERL%%/Test/Deep/Set.pm
+%%SITE_PERL%%/Test/Deep/Number.pm
+%%SITE_PERL%%/Test/Deep/HashEach.pm
+%%SITE_PERL%%/Test/Deep/Regexp.pm
+%%SITE_PERL%%/Test/Deep/Ignore.pm
+%%SITE_PERL%%/Test/Deep/ArrayLength.pm
+%%SITE_PERL%%/Test/Deep/Array.pm
+%%SITE_PERL%%/Test/Deep/Shallow.pm
+%%SITE_PERL%%/Test/Deep/ListMethods.pm
+%%SITE_PERL%%/Test/Deep/HashKeysOnly.pm
+%%SITE_PERL%%/Test/Deep/ArrayEach.pm
+%%SITE_PERL%%/Test/Deep/RegexpRef.pm
+%%SITE_PERL%%/Test/Deep/MM.pm
+%%SITE_PERL%%/Test/Deep/Any.pm
+%%SITE_PERL%%/Test/Deep/All.pm
+%%SITE_PERL%%/Test/Deep/ArrayElementsOnly.pm
+%%SITE_PERL%%/Test/Deep/Methods.pm
+%%SITE_PERL%%/Test/Deep/Cache.pm
+%%SITE_PERL%%/Test/Deep/HashKeys.pm
+%%SITE_PERL%%/Test/Deep/ScalarRefOnly.pm
+%%SITE_PERL%%/Test/Deep/Code.pm
+%%SITE_PERL%%/Test/Deep/Ref.pm
+%%SITE_PERL%%/Test/Deep/Blessed.pm
+%%SITE_PERL%%/Test/Deep/ScalarRef.pm
+%%SITE_PERL%%/Test/Deep.pm
+%%SITE_PERL%%/Test/Deep/RegexpRefOnly.pm
+%%SITE_PERL%%/Test/Deep/Hash.pm
+%%SITE_PERL%%/Test/Deep/Class.pm
+%%SITE_PERL%%/Test/Deep.pod
+%%SITE_PERL%%/Test/Deep/RefType.pm
+%%SITE_PERL%%/Test/Deep/Stack.pm