aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Mini-Unit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-30 11:49:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-30 11:49:50 +0000
commit05b8c7c174d204050a7a6c88291b71198917274f (patch)
treeb00f493639eb24ab93a1a49ac6112344825edd98 /devel/p5-Test-Mini-Unit
parente6a49fa893cdc720bd0c35068eb4162c6002a33d (diff)
downloadports-05b8c7c174d204050a7a6c88291b71198917274f.tar.gz
ports-05b8c7c174d204050a7a6c88291b71198917274f.zip
Notes
Diffstat (limited to 'devel/p5-Test-Mini-Unit')
-rw-r--r--devel/p5-Test-Mini-Unit/Makefile25
-rw-r--r--devel/p5-Test-Mini-Unit/distinfo2
-rw-r--r--devel/p5-Test-Mini-Unit/pkg-descr3
-rw-r--r--devel/p5-Test-Mini-Unit/pkg-plist17
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Test-Mini-Unit/Makefile b/devel/p5-Test-Mini-Unit/Makefile
new file mode 100644
index 000000000000..838778f8c12c
--- /dev/null
+++ b/devel/p5-Test-Mini-Unit/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Test-Mini-Unit
+# Date created: 2011-01-13
+# Whom: Kurt Lidl <kurt.lidl@cello.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Mini-Unit
+PORTVERSION= v1.0.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN/../../authors/id/P/PV/PVANDE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kurt.lidl@cello.com
+COMMENT= Declarative syntactic sugar for Test::Mini
+
+BUILD_DEPENDS= p5-Devel-Declare>=0.6.0:${PORTSDIR}/devel/p5-Devel-Declare \
+ p5-Test-Mini>=v1.1.1:${PORTSDIR}/devel/p5-Test-Mini
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Mini::README.3 \
+ Test::Mini::Unit.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Mini-Unit/distinfo b/devel/p5-Test-Mini-Unit/distinfo
new file mode 100644
index 000000000000..df57b072206e
--- /dev/null
+++ b/devel/p5-Test-Mini-Unit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Mini-Unit-v1.0.1.tar.gz) = deceb39636b870a7a101e318636f3e79255f8e3e948456e21505e773a0a35844
+SIZE (Test-Mini-Unit-v1.0.1.tar.gz) = 11141
diff --git a/devel/p5-Test-Mini-Unit/pkg-descr b/devel/p5-Test-Mini-Unit/pkg-descr
new file mode 100644
index 000000000000..5f662a01170c
--- /dev/null
+++ b/devel/p5-Test-Mini-Unit/pkg-descr
@@ -0,0 +1,3 @@
+Syntactic sugar for Test::Mini
+
+WWW: http://search.cpan.org/dist/Test-Mini-Unit/
diff --git a/devel/p5-Test-Mini-Unit/pkg-plist b/devel/p5-Test-Mini-Unit/pkg-plist
new file mode 100644
index 000000000000..2248febf2c24
--- /dev/null
+++ b/devel/p5-Test-Mini-Unit/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Test/Mini/README.pod
+%%SITE_PERL%%/Test/Mini/Unit.pm
+%%SITE_PERL%%/Test/Mini/Unit.pod
+%%SITE_PERL%%/Test/Mini/Unit/SharedBehavior.pm
+%%SITE_PERL%%/Test/Mini/Unit/Sugar/Advice.pm
+%%SITE_PERL%%/Test/Mini/Unit/Sugar/Reuse.pm
+%%SITE_PERL%%/Test/Mini/Unit/Sugar/Shared.pm
+%%SITE_PERL%%/Test/Mini/Unit/Sugar/Test.pm
+%%SITE_PERL%%/Test/Mini/Unit/Sugar/TestCase.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Mini/Unit/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Mini/Unit
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Mini
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Mini/Unit/Sugar
+@dirrmtry %%SITE_PERL%%/Test/Mini/Unit
+@dirrmtry %%SITE_PERL%%/Test/Mini
+@dirrmtry %%SITE_PERL%%/Test