aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-TempDir/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-09-07 02:08:31 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-09-07 02:08:31 +0000
commitaaf5353c66e6b55d554f3dbabe6c3f01af56485a (patch)
treee8b83823a79feb6df86d1682efe751661bb72f55 /devel/p5-Test-TempDir/Makefile
parent9cbc7515bdb744e8b6082d5183a8c49484295f1d (diff)
downloadports-aaf5353c66e6b55d554f3dbabe6c3f01af56485a.tar.gz
ports-aaf5353c66e6b55d554f3dbabe6c3f01af56485a.zip
Notes
Diffstat (limited to 'devel/p5-Test-TempDir/Makefile')
-rw-r--r--devel/p5-Test-TempDir/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-Test-TempDir/Makefile b/devel/p5-Test-TempDir/Makefile
new file mode 100644
index 000000000000..864f7cba4b1f
--- /dev/null
+++ b/devel/p5-Test-TempDir/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Test-TempDir
+# Date created: 2008/09/06
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-TempDir
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Temporary files support for testing
+
+RUN_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-File-Path>=0:${PORTSDIR}/devel/p5-File-Path \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp \
+ p5-File-NFSLock>=0:${PORTSDIR}/devel/p5-File-NFSLock \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::TempDir.3 Test::TempDir::Factory.3 Test::TempDir::Handle.3
+
+.include <bsd.port.mk>