aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Time-Crontab/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2014-01-12 14:45:20 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2014-01-12 14:45:20 +0000
commit9a965570f0df5acb20cb70422a4c5e1a4052aefe (patch)
treed442f2af83f41dadfb26768f434c9952fe7ddabe /devel/p5-Time-Crontab/Makefile
parent7e5662d2ab96340737031498cec747f393dc260e (diff)
Time::Crontab is a parser for crontab date and time field. And it
provides simple matcher. WWW: http://search.cpan.org/dist/Time-Crontab/
Notes
Notes: svn path=/head/; revision=339507
Diffstat (limited to 'devel/p5-Time-Crontab/Makefile')
-rw-r--r--devel/p5-Time-Crontab/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/devel/p5-Time-Crontab/Makefile b/devel/p5-Time-Crontab/Makefile
new file mode 100644
index 000000000000..7930a2ce680b
--- /dev/null
+++ b/devel/p5-Time-Crontab/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= Time-Crontab
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to parse crontab date and time field
+
+RUN_DEPENDS= \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Set-Crontab>=1.03:${PORTSDIR}/devel/p5-Set-Crontab
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>