aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tree-Binary-Dictionary
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-24 18:58:15 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-24 18:58:15 +0000
commit071e5a80bdd2fd69a64d33d2bab1afc81c31b642 (patch)
treed00b7130975f7460ac59c7ca02c218c2eade277a /devel/p5-Tree-Binary-Dictionary
parent6bbfcfd62b2e92e254d571ff53e6ade0b78e701d (diff)
downloadports-071e5a80bdd2fd69a64d33d2bab1afc81c31b642.tar.gz
ports-071e5a80bdd2fd69a64d33d2bab1afc81c31b642.zip
Notes
Diffstat (limited to 'devel/p5-Tree-Binary-Dictionary')
-rw-r--r--devel/p5-Tree-Binary-Dictionary/Makefile31
-rw-r--r--devel/p5-Tree-Binary-Dictionary/distinfo3
-rw-r--r--devel/p5-Tree-Binary-Dictionary/pkg-descr7
-rw-r--r--devel/p5-Tree-Binary-Dictionary/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Tree-Binary-Dictionary/Makefile b/devel/p5-Tree-Binary-Dictionary/Makefile
new file mode 100644
index 000000000000..47c34d043a2f
--- /dev/null
+++ b/devel/p5-Tree-Binary-Dictionary/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Tree-Binary-Dictionary
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-Binary-Dictionary
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tree
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A dictionary API to a binary tree
+
+BUILD_DEPENDS= ${SITE_PERL}/Tree/Binary.pm:${PORTSDIR}/devel/p5-Tree-Binary
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Tree::Binary::Dictionary.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.x or later. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tree-Binary-Dictionary/distinfo b/devel/p5-Tree-Binary-Dictionary/distinfo
new file mode 100644
index 000000000000..ce0f2483cded
--- /dev/null
+++ b/devel/p5-Tree-Binary-Dictionary/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tree-Binary-Dictionary-0.04.tar.gz) = 0c6c4414145a01362f08f21f07be3f7a
+SHA256 (Tree-Binary-Dictionary-0.04.tar.gz) = a23ef5b13f785fa7e508df771dc308b425569ae49f5734c24f3ebf5473052ec9
+SIZE (Tree-Binary-Dictionary-0.04.tar.gz) = 3856
diff --git a/devel/p5-Tree-Binary-Dictionary/pkg-descr b/devel/p5-Tree-Binary-Dictionary/pkg-descr
new file mode 100644
index 000000000000..dcbd56ce8091
--- /dev/null
+++ b/devel/p5-Tree-Binary-Dictionary/pkg-descr
@@ -0,0 +1,7 @@
+A simple class to provide a dictionary style API to a binary tree of data.
+
+This can provide a useful alternative to a long-lived hash in long running
+daemons and processes.
+
+WWW: http://search.cpan.org/dist/Tree-Binary-Dictionary
+Author: aaron trevena <teejay@droogs.org>
diff --git a/devel/p5-Tree-Binary-Dictionary/pkg-plist b/devel/p5-Tree-Binary-Dictionary/pkg-plist
new file mode 100644
index 000000000000..a4d964e3ac20
--- /dev/null
+++ b/devel/p5-Tree-Binary-Dictionary/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Tree/Binary/Dictionary.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Binary/Dictionary/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Binary/Dictionary
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Binary
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree
+@dirrmtry %%SITE_PERL%%/Tree/Binary
+@dirrmtry %%SITE_PERL%%/Tree