aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-perlkde/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /devel/p5-perlkde/Makefile
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
Notes
Diffstat (limited to 'devel/p5-perlkde/Makefile')
-rw-r--r--devel/p5-perlkde/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/p5-perlkde/Makefile b/devel/p5-perlkde/Makefile
new file mode 100644
index 000000000000..2ea7406c39c9
--- /dev/null
+++ b/devel/p5-perlkde/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= perlkde
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= devel kde perl5
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+PKGNAMEPREFIX= p5-
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Perl bindings for KDE
+
+USE_XZ= yes
+USE_PERL5= yes
+# Build fails with system gcc
+USE_GCC= 4.6+
+USE_KDE4= kdehier kdeprefix perlqt smokekde automoc4
+USE_QT4= qmake_build moc_build uic_build rcc_build
+USE_CMAKE= yes
+
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+
+# Respect PREFIX
+CMAKE_ARGS+= -DCUSTOM_PERL_SITE_ARCH_DIR=${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}
+
+# Fix build PREFIX != KDE4_PREFIX
+CMAKE_ARGS+= -DSmoke_DIR=${KDE4_PREFIX}/lib/cmake/smoke \
+ -DPerlQt_DIR=${KDE4_PREFIX}/share/perlqt/cmake \
+ -DOkular_DIR=${KDE4_PREFIX}/lib/cmake/Okular
+
+OPTIONS_DEFINE= ATTICA
+ATTICA_DESC= Bindings for libattica (may crash build)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MATTICA}
+.if exists(${KDE4_PREFIX}/lib/libsmokekdecore.so) && \
+ !exists(${KDE4_PREFIX}/lib/libsmokeattica.so)
+IGNORE= requires devel/smokekde built with ATTICA option
+.endif
+PLIST_SUB+= ATTICA=""
+.else
+CMAKE_ARGS+= -DWITH_LibAttica:BOOL=FALSE
+PLIST_SUB+= ATTICA="@comment "
+.endif
+
+.include <bsd.port.mk>