aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-pip/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-28 02:14:10 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-28 02:14:10 +0000
commit6bafc885baf793ae03f5ac791c0dd3a00c8a240a (patch)
tree62695bc711f71537a993f34c5d0d61410515b227 /devel/p5-pip/Makefile
parent1ebd2ae261cfbc138c7f97adf203c0ee5ceb2610 (diff)
downloadports-6bafc885baf793ae03f5ac791c0dd3a00c8a240a.tar.gz
ports-6bafc885baf793ae03f5ac791c0dd3a00c8a240a.zip
Notes
Diffstat (limited to 'devel/p5-pip/Makefile')
-rw-r--r--devel/p5-pip/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/p5-pip/Makefile b/devel/p5-pip/Makefile
index 8765205430a5..2eb8d4fe3f39 100644
--- a/devel/p5-pip/Makefile
+++ b/devel/p5-pip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pip
-PORTVERSION= 1.16
+PORTVERSION= 1.18
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/A/AD/ADAMK
@@ -15,10 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl Installation Program
-BUILD_DEPENDS= p5-CPAN-Inject>=0.07:${PORTSDIR}/devel/p5-CPAN-Inject \
+BUILD_DEPENDS= p5-Archive-Zip>=1.29:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-CPAN-Inject>=0.07:${PORTSDIR}/devel/p5-CPAN-Inject \
p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which \
p5-File-pushd>=0.32:${PORTSDIR}/devel/p5-File-pushd \
- p5-Params-Util>=0.21:${PORTSDIR}/devel/p5-Params-Util \
+ p5-PAR-Dist>=0.25:${PORTSDIR}/devel/p5-PAR-Dist \
+ p5-Params-Util>=1.00:${PORTSDIR}/devel/p5-Params-Util \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -29,4 +31,7 @@ MAN3= Module::Plan::Base.3 \
Module::Plan::Lite.3 \
pip.3
+post-configure:
+ @${REINPLACE_CMD} 's|(INST_SCRIPT)/pip|(INST_SCRIPT)/pip-perl|' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>