aboutsummaryrefslogtreecommitdiff
path: root/devel/pecl-statgrab
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-09 22:41:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-09 22:41:10 +0000
commit80b9d9837cb2a9d9bf0c43ef34354213108176b7 (patch)
treeefde6eba122b8130978223f90792e065f9fe82a7 /devel/pecl-statgrab
parent653370daa0d712c9c64278567329d2e6655db228 (diff)
downloadports-80b9d9837cb2a9d9bf0c43ef34354213108176b7.tar.gz
ports-80b9d9837cb2a9d9bf0c43ef34354213108176b7.zip
Notes
Diffstat (limited to 'devel/pecl-statgrab')
-rw-r--r--devel/pecl-statgrab/Makefile34
-rw-r--r--devel/pecl-statgrab/distinfo2
-rw-r--r--devel/pecl-statgrab/files/patch-config.m411
-rw-r--r--devel/pecl-statgrab/pkg-descr8
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/pecl-statgrab/Makefile b/devel/pecl-statgrab/Makefile
new file mode 100644
index 000000000000..2478577d5b97
--- /dev/null
+++ b/devel/pecl-statgrab/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pecl-statgrab
+# Date created: 04 April 2005
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= statgrab
+PORTVERSION= 0.3
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= Statgrab-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= tim@bishnet.net
+COMMENT= A PECL extension to retrieve information from libstatgrab
+
+LIB_DEPENDS= statgrab.6:${PORTSDIR}/devel/libstatgrab
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -ldevstat ${EXTRA_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_LIBS= -lkvm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pecl-statgrab/distinfo b/devel/pecl-statgrab/distinfo
new file mode 100644
index 000000000000..0e7a21235270
--- /dev/null
+++ b/devel/pecl-statgrab/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/Statgrab-0.3.tgz) = c2dd8a7f74de55ef273f96fc9e271512
+SIZE (PECL/Statgrab-0.3.tgz) = 5805
diff --git a/devel/pecl-statgrab/files/patch-config.m4 b/devel/pecl-statgrab/files/patch-config.m4
new file mode 100644
index 000000000000..5d2dc781cc90
--- /dev/null
+++ b/devel/pecl-statgrab/files/patch-config.m4
@@ -0,0 +1,11 @@
+--- config.m4.bak Mon Apr 4 20:14:03 2005
++++ config.m4 Mon Apr 4 20:14:20 2005
+@@ -39,7 +39,7 @@
+ ],[
+ AC_MSG_ERROR([wrong libstatgrab version or lib not found, Statgrab version 0.10+ is required.])
+ ],[
+- -L$STATGRAB_DIR/lib -lm -ldl
++ -L$STATGRAB_DIR/lib
+ ])
+ dnl
+ PHP_SUBST(STATGRAB_SHARED_LIBADD)
diff --git a/devel/pecl-statgrab/pkg-descr b/devel/pecl-statgrab/pkg-descr
new file mode 100644
index 000000000000..99ca363f2336
--- /dev/null
+++ b/devel/pecl-statgrab/pkg-descr
@@ -0,0 +1,8 @@
+libstatgrab is a library that provides a common interface for
+retrieving a variety of system statistics on a number of *NIX like
+systems.
+
+This extension allows you to call the functions made available by
+libstatgrab library.
+
+WWW: http://pecl.php.net/package/statgrab/