aboutsummaryrefslogtreecommitdiff
path: root/devel/portlint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-15 06:26:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-15 06:26:49 +0000
commitc1b62aafb150ef2e782887d824a8eb74bc08763a (patch)
tree39a6e4c1a07e5c2d52acf7b149520e411b13e808 /devel/portlint
parentcaadf1d89b7f7da67cbb4c5c21efdfdf2fd9dd18 (diff)
downloadports-c1b62aafb150ef2e782887d824a8eb74bc08763a.tar.gz
ports-c1b62aafb150ef2e782887d824a8eb74bc08763a.zip
Notes
Diffstat (limited to 'devel/portlint')
-rw-r--r--devel/portlint/Makefile2
-rw-r--r--devel/portlint/src/portlint.pl14
2 files changed, 11 insertions, 5 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 4d7b6cf69847..27b6c420efd1 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.6.4
+PORTVERSION= 2.6.5
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index 8e8b07fe1cf6..12e1b1fcd6f4 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.49 2004/06/06 17:02:32 marcus Exp $
+# $Id: portlint.pl,v 1.51 2004/06/15 06:23:42 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -40,7 +40,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 6;
-my $micro = 4;
+my $micro = 5;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -289,7 +289,7 @@ foreach my $i (@checker) {
} else {
my $proc = $checker{$i};
&$proc($i) || &perror("Cannot open the file $i\n");
- if ($proc ne 'checkpatch') {
+ if ($proc ne \&checkpatch) {
&checklastline($i)
|| &perror("Cannot open the file $i\n");
}
@@ -662,12 +662,18 @@ sub checkplist {
}
if ($_ =~ /\.la$/ && $makevar{USE_LIBTOOL_VER} eq '') {
- &perror("WARN: $file [$.]: installing libtool archives, ".
+ &perror("WARN: $file [$.]: installing libtool archives, ".
"please use USE_LIBTOOL_VER in Makefile if possible. ".
"See http://www.FreeBSD.org/gnome/docs/portlint.html ".
"for a way to completely eliminate .la files.");
}
+ if ($_ =~ m|^lib/pkgconfig/[^\.]+.pc$|) {
+ &perror("FATAL: $file [$.]: installing pkg-config files into ".
+ "lib/pkgconfig. All pkg-config files must be installed ".
+ "into libdata/pkgconfig for them to be found by pkg-config.");
+ }
+
if ($_ =~ m|^lib/lib[^\/]+\.so(\.\d+)?$| &&
$makevar{INSTALLS_SHLIB} eq '') {
&perror("WARN: $file [$.]: installing shared libraries, ".