aboutsummaryrefslogtreecommitdiff
path: root/devel/portmk/Mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2005-12-16 02:11:14 +0000
committerMark Linimon <linimon@FreeBSD.org>2005-12-16 02:11:14 +0000
commit1d5fc60b5efad3ea115943b0c05e7fe7399cf9a7 (patch)
tree1146ee043f35e4426a4e853dda38600bd16f7269 /devel/portmk/Mk
parent9c6cc6838076cff56db8eca8d9cdf3f4e99a4cc2 (diff)
downloadports-1d5fc60b5efad3ea115943b0c05e7fe7399cf9a7.tar.gz
ports-1d5fc60b5efad3ea115943b0c05e7fe7399cf9a7.zip
Notes
Diffstat (limited to 'devel/portmk/Mk')
-rw-r--r--devel/portmk/Mk/bsd.local.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/portmk/Mk/bsd.local.mk b/devel/portmk/Mk/bsd.local.mk
new file mode 100644
index 000000000000..07ff97ca883e
--- /dev/null
+++ b/devel/portmk/Mk/bsd.local.mk
@@ -0,0 +1,33 @@
+# -*- mode: Makefile; tab-width: 4; -*-
+# ex: ts=4
+#
+# bsd.local.mk - Sandbox for local modification to ports framework.
+#
+# Created by: Mark Linimon <linimon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+.if !defined(_POSTMKINCLUDED) && !defined(Local_Pre_Include)
+
+Local_Pre_Include= bsd.local.mk
+
+#
+# here is where any code that needs to run at bsd.port.pre.mk inclusion
+# time should live.
+#
+
+.endif # !defined(_POSTMKINCLUDED) && !defined(Local_Pre_Include)
+
+.if defined(_POSTMKINCLUDED) && !defined(Local_Post_Include)
+
+Local_Post_Include= bsd.local.mk
+
+#
+# here is where any code that needs to run at bsd.port.pre.mk inclusion
+# time should live.
+#
+
+.include "${DEVELPORTSDIR}/Mk/bsd.portsmon.mk"
+
+.endif # defined(_POSTMKINCLUDED) && !defined(Local_Post_Include)