aboutsummaryrefslogtreecommitdiff
path: root/devel/poslib/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:56:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:56:20 +0000
commit3618543557de774d94cff2569660ee6bd1094133 (patch)
treec68414bb4a18c1a05e7cd725c723fa141f943722 /devel/poslib/Makefile
parent1ce967df6236c1c289d1ed6ff8ebf7a9e67aa398 (diff)
downloadports-3618543557de774d94cff2569660ee6bd1094133.tar.gz
ports-3618543557de774d94cff2569660ee6bd1094133.zip
Notes
Diffstat (limited to 'devel/poslib/Makefile')
-rw-r--r--devel/poslib/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/poslib/Makefile b/devel/poslib/Makefile
new file mode 100644
index 000000000000..a140491a83fa
--- /dev/null
+++ b/devel/poslib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: poslib
+# Date created: 2003-08-03
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poslib
+PORTVERSION= 1.0
+CATEGORIES= devel dns
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= posadis
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Posadis C++ DNS library
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS} -D_REENTRANT"
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+DOCS= AUTHORS ChangeLog NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>