aboutsummaryrefslogtreecommitdiff
path: root/devel/projectcenter.app/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-22 13:15:20 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-22 13:15:20 +0000
commit364469ac832219637cc352bfbbbbb307402ea6e3 (patch)
treedb18fe4b4d821cce2aa751a7ac67048bf34c062b /devel/projectcenter.app/Makefile
parent89e94b04d8840b24b778191d1e2cd189b4add201 (diff)
downloadports-364469ac832219637cc352bfbbbbb307402ea6e3.tar.gz
ports-364469ac832219637cc352bfbbbbb307402ea6e3.zip
Notes
Diffstat (limited to 'devel/projectcenter.app/Makefile')
-rw-r--r--devel/projectcenter.app/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
new file mode 100644
index 000000000000..dae0857ebabb
--- /dev/null
+++ b/devel/projectcenter.app/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: ProjectCenter
+# Date created: 22 Sep 2000
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= projectcenter.app
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.projectcenter.ch/
+DISTNAME= ProjectCenter-000921
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/GNUstep/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep
+RUN_DEPENDS= ${LOCALBASE}/GNUstep/System/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep
+
+PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/ProjectCenter
+USE_NEWGCC= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+MAKE_ENV= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}" \
+ ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/freebsdelf/gnu-gnu-gnu-xgps"
+ALL_TARGET=
+NO_MTREE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH}
+
+# XXX This is ugly beyond measure. Don't tell anyone I did this.
+post-extract:
+ ${LN} -sf ${WRKSRC}/PCLib/*.h ${WRKSRC}/ProjectCenter
+
+# Quick workaround until I found out how to set the real path in the code
+post-patch:
+.for file in PCLib/PCBundleLoader.m ProjectCenter/PCAppController.m
+ ${PERL} -pi -e "s:@\"/usr/GNUstep:@\"${PREFIX}:g" ${WRKSRC}/${file}
+.endfor
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>