aboutsummaryrefslogtreecommitdiff
path: root/devel/ptlib26
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-23 18:53:25 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-23 18:53:25 +0000
commita8d4bc262c47ceeb4e7c5608d049ebb8524caf93 (patch)
treef088afbed1fb1f7fa09431af19042f72f976318a /devel/ptlib26
parent52c94abc25119aac83464d84197c3e7040bf8aa9 (diff)
downloadports-a8d4bc262c47ceeb4e7c5608d049ebb8524caf93.tar.gz
ports-a8d4bc262c47ceeb4e7c5608d049ebb8524caf93.zip
Notes
Diffstat (limited to 'devel/ptlib26')
-rw-r--r--devel/ptlib26/files/patch-plugins_configure395
-rw-r--r--devel/ptlib26/files/patch-plugins_vidinput_bsd_h17
-rw-r--r--devel/ptlib26/pkg-plist112
3 files changed, 465 insertions, 59 deletions
diff --git a/devel/ptlib26/files/patch-plugins_configure b/devel/ptlib26/files/patch-plugins_configure
new file mode 100644
index 000000000000..3dba91a2b335
--- /dev/null
+++ b/devel/ptlib26/files/patch-plugins_configure
@@ -0,0 +1,395 @@
+--- plugins/configure.orig 2008-09-15 16:26:48.000000000 +0800
++++ plugins/configure 2009-02-23 20:09:39.000000000 +0800
+@@ -4993,6 +4993,268 @@ fi
+
+
+ if test "${enable_bsdvideo}z" = "yesz" ; then
++ if test "${ac_cv_header_ioctl_meteor_h+set}" = set; then
++ { echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_ioctl_meteor_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_ioctl_meteor_h" >&5
++echo "${ECHO_T}$ac_cv_header_ioctl_meteor_h" >&6; }
++else
++ # Is the header compilable?
++{ echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h usability" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_meteor.h usability... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <dev/bktr/ioctl_meteor.h>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (ac_try="$ac_compile"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_compile") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } && {
++ test -z "$ac_c_werror_flag" ||
++ test ! -s conftest.err
++ } && test -s conftest.$ac_objext; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_compiler=no
++fi
++
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6; }
++
++# Is the header present?
++{ echo "$as_me:$LINENO: checking dev/bktr/ioctl_meteor.h presence" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_meteor.h presence... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <dev/bktr/ioctl_meteor.h>
++_ACEOF
++if { (ac_try="$ac_cpp conftest.$ac_ext"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null && {
++ test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
++ test ! -s conftest.err
++ }; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++
++rm -f conftest.err conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6; }
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_meteor.h: in the future, the compiler will take precedence" >&2;}
++
++ ;;
++esac
++{ echo "$as_me:$LINENO: checking for dev/bktr/ioctl_meteor.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_meteor.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_ioctl_meteor_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_cv_header_ioctl_meteor_h=$ac_header_preproc
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_ioctl_meteor_h" >&5
++echo "${ECHO_T}$ac_cv_header_ioctl_meteor_h" >&6; }
++
++fi
++if test $ac_cv_header_ioctl_meteor_h = yes; then
++ BSDVIDEOHDR=1
++fi
++
++
++ if test "${ac_cv_header_ioctl_bt848_h+set}" = set; then
++ { echo "$as_me:$LINENO: checking for dev/bktr/ioctl_bt848.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_bt848.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_ioctl_bt848_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_ioctl_bt848_h" >&5
++echo "${ECHO_T}$ac_cv_header_ioctl_bt848_h" >&6; }
++else
++ # Is the header compilable?
++{ echo "$as_me:$LINENO: checking dev/bktr/ioctl_bt848.h usability" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_bt848.h usability... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <dev/bktr/ioctl_bt848.h>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (ac_try="$ac_compile"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_compile") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } && {
++ test -z "$ac_c_werror_flag" ||
++ test ! -s conftest.err
++ } && test -s conftest.$ac_objext; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_compiler=no
++fi
++
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6; }
++
++# Is the header present?
++{ echo "$as_me:$LINENO: checking dev/bktr/ioctl_bt848.h presence" >&5
++echo $ECHO_N "checking dev/bktr/ioctl_bt848.h presence... $ECHO_C" >&6; }
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <dev/bktr/ioctl_bt848.h>
++_ACEOF
++if { (ac_try="$ac_cpp conftest.$ac_ext"
++case "(($ac_try" in
++ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++ *) ac_try_echo=$ac_try;;
++esac
++eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
++ (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null && {
++ test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
++ test ! -s conftest.err
++ }; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++
++rm -f conftest.err conftest.$ac_ext
++{ echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6; }
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: dev/bktr/ioctl_bt848.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: dev/bktr/ioctl_bt848.h: in the future, the compiler will take precedence" >&2;}
++
++ ;;
++esac
++{ echo "$as_me:$LINENO: checking for dev/bktr/ioctl_bt848.h" >&5
++echo $ECHO_N "checking for dev/bktr/ioctl_bt848.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_ioctl_bt848_h+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_cv_header_ioctl_bt848_h=$ac_header_preproc
++fi
++{ echo "$as_me:$LINENO: result: $ac_cv_header_ioctl_bt848_h" >&5
++echo "${ECHO_T}$ac_cv_header_ioctl_bt848_h" >&6; }
++
++fi
++if test $ac_cv_header_ioctl_bt848_h = yes; then
++ BSDVIDEOHDR=1
++fi
++
++
++# old path
++if test "$ac_cv_header_ioctl_bt848_h" != yes -a "$ac_cv_header_ioctl_meteor_h" != yes; then
+ if test "${ac_cv_header_machine_ioctl_meteor_h+set}" = set; then
+ { echo "$as_me:$LINENO: checking for machine/ioctl_meteor.h" >&5
+ echo $ECHO_N "checking for machine/ioctl_meteor.h... $ECHO_C" >&6; }
+@@ -5123,18 +5385,18 @@ if test $ac_cv_header_machine_ioctl_mete
+ fi
+
+
+- if test "${ac_cv_header_i386_ioctl_meteor_h+set}" = set; then
+- { echo "$as_me:$LINENO: checking for i386/ioctl_meteor.h" >&5
+-echo $ECHO_N "checking for i386/ioctl_meteor.h... $ECHO_C" >&6; }
+-if test "${ac_cv_header_i386_ioctl_meteor_h+set}" = set; then
++ if test "${ac_cv_header_machine_ioctl_bt848_h+set}" = set; then
++ { echo "$as_me:$LINENO: checking for machine/ioctl_bt848.h" >&5
++echo $ECHO_N "checking for machine/ioctl_bt848.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_machine_ioctl_bt848_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ fi
+-{ echo "$as_me:$LINENO: result: $ac_cv_header_i386_ioctl_meteor_h" >&5
+-echo "${ECHO_T}$ac_cv_header_i386_ioctl_meteor_h" >&6; }
++{ echo "$as_me:$LINENO: result: $ac_cv_header_machine_ioctl_bt848_h" >&5
++echo "${ECHO_T}$ac_cv_header_machine_ioctl_bt848_h" >&6; }
+ else
+ # Is the header compilable?
+-{ echo "$as_me:$LINENO: checking i386/ioctl_meteor.h usability" >&5
+-echo $ECHO_N "checking i386/ioctl_meteor.h usability... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking machine/ioctl_bt848.h usability" >&5
++echo $ECHO_N "checking machine/ioctl_bt848.h usability... $ECHO_C" >&6; }
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -5142,7 +5404,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
+-#include <i386/ioctl_meteor.h>
++#include <machine/ioctl_bt848.h>
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (ac_try="$ac_compile"
+@@ -5174,15 +5436,15 @@ rm -f core conftest.err conftest.$ac_obj
+ echo "${ECHO_T}$ac_header_compiler" >&6; }
+
+ # Is the header present?
+-{ echo "$as_me:$LINENO: checking i386/ioctl_meteor.h presence" >&5
+-echo $ECHO_N "checking i386/ioctl_meteor.h presence... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking machine/ioctl_bt848.h presence" >&5
++echo $ECHO_N "checking machine/ioctl_bt848.h presence... $ECHO_C" >&6; }
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <i386/ioctl_meteor.h>
++#include <machine/ioctl_bt848.h>
+ _ACEOF
+ if { (ac_try="$ac_cpp conftest.$ac_ext"
+ case "(($ac_try" in
+@@ -5215,43 +5477,44 @@ echo "${ECHO_T}$ac_header_preproc" >&6;
+ # So? What about this header?
+ case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
+ yes:no: )
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: proceeding with the compiler's result" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: proceeding with the compiler's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: proceeding with the compiler's result" >&2;}
+ ac_header_preproc=yes
+ ;;
+ no:yes:* )
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: present but cannot be compiled" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: present but cannot be compiled" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: check for missing prerequisite headers?" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: check for missing prerequisite headers?" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: see the Autoconf documentation" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: see the Autoconf documentation" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: section \"Present But Cannot Be Compiled\"" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: proceeding with the preprocessor's result" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: proceeding with the preprocessor's result" >&2;}
+- { echo "$as_me:$LINENO: WARNING: i386/ioctl_meteor.h: in the future, the compiler will take precedence" >&5
+-echo "$as_me: WARNING: i386/ioctl_meteor.h: in the future, the compiler will take precedence" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: machine/ioctl_bt848.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: machine/ioctl_bt848.h: in the future, the compiler will take precedence" >&2;}
+
+ ;;
+ esac
+-{ echo "$as_me:$LINENO: checking for i386/ioctl_meteor.h" >&5
+-echo $ECHO_N "checking for i386/ioctl_meteor.h... $ECHO_C" >&6; }
+-if test "${ac_cv_header_i386_ioctl_meteor_h+set}" = set; then
++{ echo "$as_me:$LINENO: checking for machine/ioctl_bt848.h" >&5
++echo $ECHO_N "checking for machine/ioctl_bt848.h... $ECHO_C" >&6; }
++if test "${ac_cv_header_machine_ioctl_bt848_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+- ac_cv_header_i386_ioctl_meteor_h=$ac_header_preproc
++ ac_cv_header_machine_ioctl_bt848_h=$ac_header_preproc
+ fi
+-{ echo "$as_me:$LINENO: result: $ac_cv_header_i386_ioctl_meteor_h" >&5
+-echo "${ECHO_T}$ac_cv_header_i386_ioctl_meteor_h" >&6; }
++{ echo "$as_me:$LINENO: result: $ac_cv_header_machine_ioctl_bt848_h" >&5
++echo "${ECHO_T}$ac_cv_header_machine_ioctl_bt848_h" >&6; }
+
+ fi
+-if test $ac_cv_header_i386_ioctl_meteor_h = yes; then
++if test $ac_cv_header_machine_ioctl_bt848_h = yes; then
+ BSDVIDEOHDR=1
+ fi
+-
++fi
++# old path - end
+
+ if test "${ac_cv_header_dev_ic_bt8xx_h+set}" = set; then
+ { echo "$as_me:$LINENO: checking for dev/ic/bt8xx.h" >&5
diff --git a/devel/ptlib26/files/patch-plugins_vidinput_bsd_h b/devel/ptlib26/files/patch-plugins_vidinput_bsd_h
index 913e457670ad..204c610a4b3d 100644
--- a/devel/ptlib26/files/patch-plugins_vidinput_bsd_h
+++ b/devel/ptlib26/files/patch-plugins_vidinput_bsd_h
@@ -1,6 +1,17 @@
---- plugins/vidinput_bsd/vidinput_bsd.h.orig 2009-01-11 17:52:59.000000000 -0500
-+++ plugins/vidinput_bsd/vidinput_bsd.h 2009-01-26 17:55:00.000000000 -0500
-@@ -62,7 +62,7 @@
+--- plugins/vidinput_bsd/vidinput_bsd.h.orig 2009-01-12 06:52:59.000000000 +0800
++++ plugins/vidinput_bsd/vidinput_bsd.h 2009-02-23 16:33:18.000000000 +0800
+@@ -17,8 +17,10 @@
+ #include <sys/param.h>
+ # if __FreeBSD_version >= 502100
+ #include <dev/bktr/ioctl_meteor.h>
++#include <dev/bktr/ioctl_bt848.h>
+ # else
+ #include <machine/ioctl_meteor.h>
++#include <machine/ioctl_bt848.h>
+ # endif
+ #endif
+
+@@ -62,7 +64,7 @@ public:
static PStringList GetInputDeviceNames();
diff --git a/devel/ptlib26/pkg-plist b/devel/ptlib26/pkg-plist
index 26372f97e601..44cc2c7ec5b7 100644
--- a/devel/ptlib26/pkg-plist
+++ b/devel/ptlib26/pkg-plist
@@ -1,4 +1,5 @@
bin/ptlib-config
+include/ptbuildopts.h
include/ptclib/asnber.h
include/ptclib/asner.h
include/ptclib/asnper.h
@@ -55,49 +56,7 @@ include/ptclib/xmpp.h
include/ptclib/xmpp_c2s.h
include/ptclib/xmpp_muc.h
include/ptclib/xmpp_roster.h
-@dirrm include/ptclib
-include/ptlib/unix/ptlib/beaudio.h
-include/ptlib/unix/ptlib/bevideo.h
-include/ptlib/unix/ptlib/channel.h
-include/ptlib/unix/ptlib/conchan.h
-include/ptlib/unix/ptlib/config.h
-include/ptlib/unix/ptlib/contain.h
-include/ptlib/unix/ptlib/critsec.h
-include/ptlib/unix/ptlib/dynalink.h
-include/ptlib/unix/ptlib/ethsock.h
-include/ptlib/unix/ptlib/file.h
-include/ptlib/unix/ptlib/filepath.h
-include/ptlib/unix/ptlib/icmpsock.h
-include/ptlib/unix/ptlib/ipdsock.h
-include/ptlib/unix/ptlib/ipsock.h
-include/ptlib/unix/ptlib/maccoreaudio.h
-include/ptlib/unix/ptlib/mutex.h
-include/ptlib/unix/ptlib/pdirect.h
-include/ptlib/unix/ptlib/pipechan.h
-include/ptlib/unix/ptlib/pmachdep.h
-include/ptlib/unix/ptlib/pprocess.h
-include/ptlib/unix/ptlib/ptime.h
-include/ptlib/unix/ptlib/ptlib.inl
-include/ptlib/unix/ptlib/remconn.h
-include/ptlib/unix/ptlib/resampler.h
-include/ptlib/unix/ptlib/semaphor.h
-include/ptlib/unix/ptlib/serchan.h
-include/ptlib/unix/ptlib/sfile.h
-include/ptlib/unix/ptlib/shmvideo.h
-include/ptlib/unix/ptlib/socket.h
-include/ptlib/unix/ptlib/sound.h
-include/ptlib/unix/ptlib/svcproc.h
-include/ptlib/unix/ptlib/syncpoint.h
-include/ptlib/unix/ptlib/tcpsock.h
-include/ptlib/unix/ptlib/textfile.h
-include/ptlib/unix/ptlib/thread.h
-include/ptlib/unix/ptlib/timeint.h
-include/ptlib/unix/ptlib/timer.h
-include/ptlib/unix/ptlib/udpsock.h
-include/ptlib/unix/ptlib/video.h
-include/ptlib/unix/ptlib/videoio.h
-@dirrm include/ptlib/unix/ptlib
-@dirrm include/ptlib/unix
+include/ptlib.h
include/ptlib/MacMainIf.h
include/ptlib/args.h
include/ptlib/array.h
@@ -156,13 +115,54 @@ include/ptlib/thread.h
include/ptlib/timeint.h
include/ptlib/timer.h
include/ptlib/udpsock.h
+include/ptlib/unix/ptlib/beaudio.h
+include/ptlib/unix/ptlib/bevideo.h
+include/ptlib/unix/ptlib/channel.h
+include/ptlib/unix/ptlib/conchan.h
+include/ptlib/unix/ptlib/config.h
+include/ptlib/unix/ptlib/contain.h
+include/ptlib/unix/ptlib/critsec.h
+include/ptlib/unix/ptlib/dynalink.h
+include/ptlib/unix/ptlib/ethsock.h
+include/ptlib/unix/ptlib/file.h
+include/ptlib/unix/ptlib/filepath.h
+include/ptlib/unix/ptlib/icmpsock.h
+include/ptlib/unix/ptlib/ipdsock.h
+include/ptlib/unix/ptlib/ipsock.h
+include/ptlib/unix/ptlib/maccoreaudio.h
+include/ptlib/unix/ptlib/mutex.h
+include/ptlib/unix/ptlib/pdirect.h
+include/ptlib/unix/ptlib/pipechan.h
+include/ptlib/unix/ptlib/pmachdep.h
+include/ptlib/unix/ptlib/pprocess.h
+include/ptlib/unix/ptlib/ptime.h
+include/ptlib/unix/ptlib/ptlib.inl
+include/ptlib/unix/ptlib/remconn.h
+include/ptlib/unix/ptlib/resampler.h
+include/ptlib/unix/ptlib/semaphor.h
+include/ptlib/unix/ptlib/serchan.h
+include/ptlib/unix/ptlib/sfile.h
+include/ptlib/unix/ptlib/shmvideo.h
+include/ptlib/unix/ptlib/socket.h
+include/ptlib/unix/ptlib/sound.h
+include/ptlib/unix/ptlib/svcproc.h
+include/ptlib/unix/ptlib/syncpoint.h
+include/ptlib/unix/ptlib/tcpsock.h
+include/ptlib/unix/ptlib/textfile.h
+include/ptlib/unix/ptlib/thread.h
+include/ptlib/unix/ptlib/timeint.h
+include/ptlib/unix/ptlib/timer.h
+include/ptlib/unix/ptlib/udpsock.h
+include/ptlib/unix/ptlib/video.h
+include/ptlib/unix/ptlib/videoio.h
include/ptlib/vconvert.h
include/ptlib/video.h
include/ptlib/videoio.h
include/ptlib/videoio1394dc.h
-@dirrm include/ptlib
-include/ptbuildopts.h
-include/ptlib.h
+lib/libpt.so
+lib/libpt.so.2
+lib/libpt_s.a
+libdata/pkgconfig/ptlib.pc
share/ptlib/make/common.mak
share/ptlib/make/lib.mak
share/ptlib/make/plugins.mak
@@ -170,15 +170,15 @@ share/ptlib/make/ptbuildopts.mak
share/ptlib/make/ptlib-config
share/ptlib/make/ptlib.mak
share/ptlib/make/unix.mak
+%%BSDVIDEO%%lib/ptlib-2.4.4/devices/videoinput/bsdvideo_pwplugin.so
+%%BSDVIDEO%%lib/ptlib-2.4.4/devices/sound/oss_pwplugin.so
@dirrm share/ptlib/make
@dirrm share/ptlib
-lib/ptlib-2.4.4/devices/sound/oss_pwplugin.so
-@dirrm lib/ptlib-2.4.4/devices/sound
-lib/ptlib-2.4.4/devices/videoinput/bsdvideo_pwplugin.so
-@dirrm lib/ptlib-2.4.4/devices/videoinput
-@dirrm lib/ptlib-2.4.4/devices
-@dirrm lib/ptlib-2.4.4
-lib/libpt.so.2
-lib/libpt.so
-lib/libpt_s.a
-libdata/pkgconfig/ptlib.pc
+@dirrm include/ptlib/unix/ptlib
+@dirrm include/ptlib/unix
+@dirrm include/ptlib
+@dirrm include/ptclib
+%%BSDVIDEO%%@dirrm lib/ptlib-2.4.4/devices/videoinput
+%%BSDVIDEO%%@dirrm lib/ptlib-2.4.4/devices/sound
+%%BSDVIDEO%%@dirrm lib/ptlib-2.4.4/devices
+%%BSDVIDEO%%@dirrm lib/ptlib-2.4.4