aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ctypesgen/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-25 13:33:51 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-25 13:33:51 +0000
commit79b8c5384e39171c2e1e177f766e5d83aff3ea19 (patch)
treeaf6f16d6e57decd64bffe3adbeb445dc6398fad5 /devel/py-ctypesgen/Makefile
parentd5a8758b5033c242df12ef5d1a3e3be016a4b7d9 (diff)
downloadports-79b8c5384e39171c2e1e177f766e5d83aff3ea19.tar.gz
ports-79b8c5384e39171c2e1e177f766e5d83aff3ea19.zip
Diffstat (limited to 'devel/py-ctypesgen/Makefile')
-rw-r--r--devel/py-ctypesgen/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/py-ctypesgen/Makefile b/devel/py-ctypesgen/Makefile
new file mode 100644
index 000000000000..299fcb5140f6
--- /dev/null
+++ b/devel/py-ctypesgen/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= ctypesgen
+PORTVERSION= 1.0.2
+DISTVERSIONPREFIX= ctypesgen-
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python wrapper generator for ctypes
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+ shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= davidjamesca
+
+SHEBANG_FILES= ctypesgen/test/testsuite.py
+
+.include <bsd.port.mk>