aboutsummaryrefslogtreecommitdiff
path: root/devel/py-deliciousapi
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-02-17 13:45:48 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-02-17 13:45:48 +0000
commita039d16bfaf021a0e591da1f47aa5c470a371de4 (patch)
tree88c5a00bc6fc14bf66374c8dd2373f1d1e05b66c /devel/py-deliciousapi
parent148dbec8a2c86f4c8193a88a011cab30d136c56e (diff)
downloadports-a039d16bfaf021a0e591da1f47aa5c470a371de4.tar.gz
ports-a039d16bfaf021a0e591da1f47aa5c470a371de4.zip
Notes
Diffstat (limited to 'devel/py-deliciousapi')
-rw-r--r--devel/py-deliciousapi/Makefile29
-rw-r--r--devel/py-deliciousapi/distinfo3
-rw-r--r--devel/py-deliciousapi/pkg-descr18
3 files changed, 50 insertions, 0 deletions
diff --git a/devel/py-deliciousapi/Makefile b/devel/py-deliciousapi/Makefile
new file mode 100644
index 000000000000..5f096ee246fb
--- /dev/null
+++ b/devel/py-deliciousapi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-deliciousapi
+# Date created: 2010-02-10
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deliciousapi
+PORTVERSION= 1.5.15
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= DeliciousAPI-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Unofficial Python API for retrieving data from Delicious.com
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/BeautifulSoup.py:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=1.7:${PORTSDIR}/devel/py-simplejson
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= DeliciousAPI
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyc \
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-deliciousapi/distinfo b/devel/py-deliciousapi/distinfo
new file mode 100644
index 000000000000..bd8fa05f0177
--- /dev/null
+++ b/devel/py-deliciousapi/distinfo
@@ -0,0 +1,3 @@
+MD5 (DeliciousAPI-1.5.15.tar.gz) = 87c8084434c17edeb7ca91fa1b42de8e
+SHA256 (DeliciousAPI-1.5.15.tar.gz) = 75d8467ef1848d5d0209e07d71217f27d8079c79f1e9de2098290db4f0fd8b4b
+SIZE (DeliciousAPI-1.5.15.tar.gz) = 20190
diff --git a/devel/py-deliciousapi/pkg-descr b/devel/py-deliciousapi/pkg-descr
new file mode 100644
index 000000000000..4028e1683a46
--- /dev/null
+++ b/devel/py-deliciousapi/pkg-descr
@@ -0,0 +1,18 @@
+Unofficial Python API for retrieving data from Delicious.com.
+
+This module provides the following features plus some more:
+
+* retrieving a URL's full public bookmarking history including
+* users who bookmarked the URL including tags used for such bookmarks
+ and the creation time of the bookmark (up to YYYY-MM-DD granularity)
+* top tags (up to a maximum of 10) including tag count
+* title as stored on Delicious.com
+* total number of bookmarks/users for this URL at Delicious.com
+* retrieving a user's full bookmark collection, including any private bookmarks
+if you know the corresponding password
+* retrieving a user's full public tagging vocabulary, i.e. tags and tag counts
+* retrieving a user's network information (network members and network fans)
+* HTTP proxy support
+* updated to support Delicious.com "version 2" (mini-relaunch as of August 2008)
+
+WWW: http://www.michael-noll.com/wiki/Del.icio.us_Python_API