aboutsummaryrefslogtreecommitdiff
path: root/devel/py-jsonlines/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-26 22:29:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-26 22:29:50 +0000
commitbcd87388439d32e221f9c39ad9a7729e8176c883 (patch)
tree2bf59363d3a92cfd791145f424e43edfd15fd614 /devel/py-jsonlines/Makefile
parent94bbf6ecc3b0746fa531533603c94efe00bf33e1 (diff)
downloadports-bcd87388439d32e221f9c39ad9a7729e8176c883.tar.gz
ports-bcd87388439d32e221f9c39ad9a7729e8176c883.zip
Notes
Diffstat (limited to 'devel/py-jsonlines/Makefile')
-rw-r--r--devel/py-jsonlines/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/py-jsonlines/Makefile b/devel/py-jsonlines/Makefile
new file mode 100644
index 000000000000..d0fdd041cb7c
--- /dev/null
+++ b/devel/py-jsonlines/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jsonlines
+PORTVERSION= 1.2.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library with helpers for the jsonlines file format
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>