aboutsummaryrefslogtreecommitdiff
path: root/devel/py-libvirt/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-12-31 07:56:15 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-12-31 07:56:15 +0000
commitb2ab3ab827945bddd304c48afae78f09ffce956a (patch)
tree54bfad936d73ade15c4af6a73f299404e5f299f4 /devel/py-libvirt/Makefile
parentf48f86101a9c53a2ae9362fc2f0b4f5aefcaf33c (diff)
downloadports-b2ab3ab827945bddd304c48afae78f09ffce956a.tar.gz
ports-b2ab3ab827945bddd304c48afae78f09ffce956a.zip
Notes
Diffstat (limited to 'devel/py-libvirt/Makefile')
-rw-r--r--devel/py-libvirt/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/py-libvirt/Makefile b/devel/py-libvirt/Makefile
new file mode 100644
index 000000000000..589d8680182c
--- /dev/null
+++ b/devel/py-libvirt/Makefile
@@ -0,0 +1,38 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libvirt
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+MASTER_SITES= http://libvirt.org/sources/python/ \
+ ftp://libvirt.org/libvirt/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-python-${PORTVERSION}
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Python bindings for Libvirt virtualization API
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libvirt.so:${PORTSDIR}/devel/libvirt
+
+USES= pkgconfig shebangfix
+SHEBANG_LANG= python
+SHEBANG_FILES= generator.py sanitytest.py setup.py
+
+USE_PYTHON_BUILD= yes
+USE_PYTHON_RUN= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_NOEGGINFO= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|"python"|"${PYTHON_CMD}"|g' \
+ ${WRKSRC}/setup.py
+
+post-install:
+.for lib in libvirtmod libvirtmod_qemu libvirtmod_lxc
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_LIBDIR}/site-packages/${lib}.so
+.endfor
+
+.include <bsd.port.mk>